Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 973711 - e1000e: probe of 0000:00:19.0 failed with error -2
e1000e: probe of 0000:00:19.0 failed with error -2
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 10:34 EDT by Giacomo Montagner
Modified: 2013-07-02 09:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 09:11:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giacomo Montagner 2013-06-12 10:34:00 EDT
Description of problem:
Driver e1000e is unable to handle ethernet card

Version-Release number of selected component (if applicable):
kernel 3.9.4-200.fc18.x86_64
e1000e 2.2.14-k


How reproducible:
Always.
Boot a newly installed F18

Actual results:

[    3.225477] e1000e: Intel(R) PRO/1000 Network Driver - 2.2.14-k
[    3.225479] e1000e: Copyright(c) 1999 - 2013 Intel Corporation.
[    3.225718] e1000e 0000:00:19.0: setting latency timer to 64
[    3.225790] e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    3.225833] e1000e 0000:00:19.0: irq 45 for MSI/MSI-X
[    3.853775] e1000e: probe of 0000:00:19.0 failed with error -2


00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
    Subsystem: Hewlett-Packard Company Device [103c:1619]


Expected results:

Working ethernet card.

Additional info:

Hardware is: 

00:19.0 Ethernet controller [0200]: Intel Corporation 82579LM Gigabit Network Connection [8086:1502] (rev 04)
    Subsystem: Hewlett-Packard Company Device [103c:1619]

on HP ProBook 6560b


Booting with pcie_aspm=off FIXES the problem.
Comment 1 Josh Boyer 2013-07-01 14:15:39 EDT
Can you attach the output of dmesg?
Comment 2 Giacomo Montagner 2013-07-02 02:12:52 EDT
I'm unable to reproduce the problem. Upgrades apparently fixed it and removing the pcie_aspm=off parameter does not affect the situation, the driver is still functional.
Comment 3 Josh Boyer 2013-07-02 09:11:08 EDT
OK.  We'll close this out for now.  If you see this issue again on 3.9.8 or newer kernels, please reopen and attach the output of dmesg.

Note You need to log in before you can comment on or make changes to this bug.