Bug 973713 - File::Spec::VMS not usable due missing VMS/Filespec.pm
Summary: File::Spec::VMS not usable due missing VMS/Filespec.pm
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-PathTools (Show other bugs)
(Show other bugs)
Version: 19
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-12 14:34 UTC by Lukas Zachar
Modified: 2013-10-07 06:21 UTC (History)
3 users (show)

Fixed In Version: perl-PathTools-3.40-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 06:21:34 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lukas Zachar 2013-06-12 14:34:57 UTC
Description of problem:

Perl module File::Spec::VMS is not usable on Fedora as no package provides its requirement of VMS::Filespec.

# yum provides 'perl(VMS::Filespec)'
No matches found


Version-Release number of selected component (if applicable):
perl-PathTools-3.40-1.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1. perl -e 'use File::Spec::VMS'
2.
3.

Actual results:
Can't locate VMS/Filespec.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/lib64/perl5/vendor_perl/File/Spec/VMS.pm line 13.
BEGIN failed--compilation aborted at /usr/lib64/perl5/vendor_perl/File/Spec/VMS.pm line 13.

Expected results:
no such error

Additional info:
Line 13: 'use VMS::Filespec;'

Comment 1 Petr Pisar 2013-06-14 08:06:50 UTC
It's not possible to use File::Spec::VMS without VMS::Filespec, and VMS::Filespec is not installed on Linux because it depends on VMS native code. (There is a pure-Perl implementation of VMS::Filespec, but it's not production-ready as is disabled by upstream (vms/ext/Filespec.pm).)

Also File::Spec documentation states:

> Since some modules (like VMS) make use of facilities available
> only under that OS, it may not be possible to load all modules under all
> operating systems.

Currently, only the File::Spec::VMS is not possible to use on Linux. Thus I'm going to resolve this issue by removing File::Spec::VMS from the distribution.

Comment 2 Fedora Update System 2013-06-14 08:46:39 UTC
perl-PathTools-3.40-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-PathTools-3.40-2.fc19

Comment 3 Fedora Update System 2013-06-18 10:12:30 UTC
perl-5.16.3-265.fc19,perl-CPANPLUS-Dist-Build-0.70-2.fc19,perl-CPANPLUS-0.91.38-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-5.16.3-265.fc19,perl-CPANPLUS-Dist-Build-0.70-2.fc19,perl-CPANPLUS-0.91.38-1.fc19

Comment 4 Fedora Update System 2013-06-29 18:29:52 UTC
perl-5.16.3-265.fc19, perl-CPANPLUS-Dist-Build-0.70-2.fc19, perl-CPANPLUS-0.91.38-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Fedora Update System 2013-06-29 18:38:02 UTC
perl-PathTools-3.40-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2013-07-12 11:47:20 UTC
perl-PathTools-3.40-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/perl-PathTools-3.40-3.fc19

Comment 7 Fedora Update System 2013-07-22 00:28:47 UTC
perl-PathTools-3.40-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Admin XMLRPC Client 2013-08-12 12:19:46 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.


Note You need to log in before you can comment on or make changes to this bug.