Bug 97374 - JDE debugging not working, bad docs
Summary: JDE debugging not working, bad docs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xemacs   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-13 20:07 UTC by Christopher Wong
Modified: 2015-01-08 00:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-15 05:47:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christopher Wong 2003-06-13 20:07:06 UTC
From Bugzilla Helper:
User-Agent: Opera/7.11 (Linux 2.4.20-9 i686; U)  [en]

Description of problem:
I am having a hard time getting JDE to run the debugger in XEmacs. For one 
thing, the docs seem out of sync with JDE. You cannot set jde-sourcepath from 
"custom", for example, because the documented menu items are missing (they are 
elsewhere). You can't start the debugger with jde-db because there is no such 
command. Even after fudging through the necessary settings, I could not set 
breakpoints.

Version-Release number of selected component (if applicable):
xemacs-21.4.12-6

How reproducible:
Always

Steps to Reproduce:
1. Set the classpath, sourcepath and JDK variables through JDE/Project/Options.
2. Attempt to toggle a breakpoint 

Get: "Symbol's function definition is void: line-end-position". This happens 
with both Jdb and JDEbug debuggers.

Additional info:

Comment 1 Jens Petersen 2003-07-22 12:30:45 UTC
This looks ok to me now with the current xemacs/xemacs-sumo.
Could you please try to test with the latest packages?



Note You need to log in before you can comment on or make changes to this bug.