Bug 973740 - Do not leave migration metadata in place as a result of validate-gear
Do not leave migration metadata in place as a result of validate-gear
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 11:21 EDT by Paul Morie
Modified: 2015-05-14 19:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:53:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morie 2013-06-12 11:21:09 EDT
Currently in the migrations we leave the migration metadata in place if the gear status after migration is not what we expect.  Instead, we should just log the status - as leaving the migration metadata in place has left a lot of gears with metadata in production.
Comment 1 openshift-github-bot 2013-06-12 18:17:54 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/94b91bdfd736400b8c35274a5086547c6635a268
Fix bug 973740: do not leave migration metadata in place due to gear status
Comment 2 Paul Morie 2013-06-12 18:25:25 EDT
Will be present in devenv 3354
Comment 3 Xiaoli Tian 2013-06-14 07:19:18 EDT
(In reply to Paul Morie from comment #2)
> Will be present in devenv 3354

Verified it on devenv-stage_375: 

set problem =1 to simulate the problem error:
Will find the following log after running migration

Post-migration response code: 200
Problem detected with gear status:
Cart status for python [OK]: CLIENT_RESULT: Application is running
CLIENT_RESULT: %

Did not find metadata left in the gear.

Note You need to log in before you can comment on or make changes to this bug.