Bug 973747 - IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making ...
IOException: Partition(s) 3 on /dev/sda have been written, but we have been u...
Status: CLOSED DUPLICATE of bug 964147
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:04bcc6eff86cdc2b71b0d371968...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 11:33 EDT by Mark Hamzy
Modified: 2013-06-20 21:47 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 21:47:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (544.17 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: anaconda.log (15.74 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: backtrace (1.68 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: environ (574 bytes, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: ifcfg.log (436 bytes, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: ks.cfg (1.37 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: lsblk_output (2.39 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: nmcli_dev_list (1.25 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: packaging.log (27.37 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: program.log (66.72 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: storage.log (342.66 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details
File: syslog (57.20 KB, text/plain)
2013-06-12 11:34 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2013-06-12 11:33:55 EDT
Description of problem:
Tried unattended kickstart installation but received the no disks selected error.  When I went to the installation destination, clicked done, and then reclaimed space on sda, I received this error.
The following was filed automatically by anaconda:
anaconda 19.30.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 214, in commit
    return self.__disk.commit()
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/formats/disklabel.py", line 292, in commit
    self.partedDisk.commit()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1569, in _destroy
    self.disk.originalFormat.commit()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 821, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.

Version-Release number of selected component:
anaconda-19.30.3-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   ro  inst.vnc inst.sshd ip=9.5.114.36::9.5.114.1:255.255.255.0:sharpie.rch.stglabs.ibm.com:eth0:none ip=9.5.114.41::9.5.114.1:255.255.255.0::eth1:none nameserver=9.10.244.100 bootdev=eth0 ks=http://chukar.rch.stglabs.ibm.com/Fedora19-sharpie-lvm_auto-cdrom-gnome-ks.cfg
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-300.fc19.ppc64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 821, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1569, in _destroy
    self.disk.originalFormat.commit()
  File "/usr/lib/python2.7/site-packages/blivet/formats/disklabel.py", line 292, in commit
    self.partedDisk.commit()
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 214, in commit
    return self.__disk.commit()
IOException: Partition(s) 3 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
Comment 1 Mark Hamzy 2013-06-12 11:34:03 EDT
Created attachment 760210 [details]
File: anaconda-tb
Comment 2 Mark Hamzy 2013-06-12 11:34:07 EDT
Created attachment 760211 [details]
File: anaconda.log
Comment 3 Mark Hamzy 2013-06-12 11:34:11 EDT
Created attachment 760212 [details]
File: backtrace
Comment 4 Mark Hamzy 2013-06-12 11:34:15 EDT
Created attachment 760213 [details]
File: environ
Comment 5 Mark Hamzy 2013-06-12 11:34:19 EDT
Created attachment 760214 [details]
File: ifcfg.log
Comment 6 Mark Hamzy 2013-06-12 11:34:23 EDT
Created attachment 760215 [details]
File: ks.cfg
Comment 7 Mark Hamzy 2013-06-12 11:34:27 EDT
Created attachment 760216 [details]
File: lsblk_output
Comment 8 Mark Hamzy 2013-06-12 11:34:32 EDT
Created attachment 760217 [details]
File: nmcli_dev_list
Comment 9 Mark Hamzy 2013-06-12 11:34:36 EDT
Created attachment 760218 [details]
File: packaging.log
Comment 10 Mark Hamzy 2013-06-12 11:34:40 EDT
Created attachment 760219 [details]
File: program.log
Comment 11 Mark Hamzy 2013-06-12 11:34:44 EDT
Created attachment 760220 [details]
File: storage.log
Comment 12 Mark Hamzy 2013-06-12 11:34:48 EDT
Created attachment 760221 [details]
File: syslog
Comment 13 David Lehman 2013-06-12 21:32:09 EDT
This should be fixed by https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-June/004530.html (bug 865213). Please retest once that fix is in place.
Comment 14 Mark Hamzy 2013-06-13 11:03:17 EDT
I tested with your patch and it seems to work for me.
Comment 15 satellitgo 2013-06-13 13:40:54 EDT
Description of problem:
try to netinstall to 4 GB USB custom ext4 4 GB no swap

Version-Release number of selected component:
anaconda-19.30.5-1.fc19.x86_64

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-Live-SoaS-x86_64-19-TC3-1 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.x86_64
other involved packages: pyparted-3.10-1.fc19.x86_64, python-libs-2.7.5-1.fc19.x86_64, python-blivet-0.15-1.fc19.noarch
packaging.log:  
product:        Fedora
release:        Fedora release 19 (Schrödinger’s Cat)
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 138, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 169, in turnOnFilesystems
    storage.doIt()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 310, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 237, in processActions
    action.execute()
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 318, in execute
    self.device.destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 821, in destroy
    self._destroy()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1569, in _destroy
    self.disk.originalFormat.commit()
  File "/usr/lib/python2.7/site-packages/blivet/formats/disklabel.py", line 292, in commit
    self.partedDisk.commit()
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 214, in commit
    return self.__disk.commit()
IOException: Partition(s) 1 on /dev/sdb have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
Comment 16 Jan Sedlák 2013-06-19 09:37:55 EDT
Tried to use DVD.iso on /dev/sda6 (ext4, extended partition) as a repository for installation (using inst.repo=hd:sda6:/DVD.iso). I was able to boot, DVD.iso was selected as installation repository, but traceback showed up during installation.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   inst.repo=nfs:nfs.englab.brq.redhat.com:/pub/fedora/fedora-alt/stage/19-TC5/Fedora/i386/iso/Fedora-19-TC5-i386-DVD.iso initrd=F19/TC5/i386/initrd.img inst.repo=hd:sda6:/DVD.iso BOOT_IMAGE=F19/TC5/i386/vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.i686
package:        anaconda-19.30.8-1
product:        Fedora
reason:         IOException: Partition(s) 6 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
release:        Cannot get release name.
version:        19-TC5
Comment 17 Brian Lane 2013-06-20 21:47:54 EDT

*** This bug has been marked as a duplicate of bug 964147 ***

Note You need to log in before you can comment on or make changes to this bug.