Bug 973771 - Can't promote a content view to a 2nd promotion path
Can't promote a content view to a 2nd promotion path
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Kedar Bidarkar
: Triaged
: 968421 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 12:50 EDT by Justin Sherrill
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:09:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-06-12 12:50:47 EDT
Description of problem:

When trying to promote a content view to a 2nd promotion path (DEV2 for example), a view will show up as 'promoted' if it has been promoted to another path (Dev1).



How reproducible:
Always

Steps to Reproduce:
1.  Create an environment Library->Dev1
2.  Create an environment Library->Dev2
3.  Create a content view definition and publish it to "TestView"
4.  Promote TestView to Dev1 via the UI
5.  Attempt to promote TestView to Dev2 via the UI

Actual results:
UI says that the view has already been promoted and does not allow promotion

Expected results:
UI does not allow promotion, says its already been promoted
Comment 1 RHEL Product and Program Management 2013-06-12 14:33:07 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Brad Buckingham 2013-09-13 17:17:05 EDT
I just ran a few tests with katello master and it appears that this may have already been solved.  I had the 3 environment paths below and was able to successfully promote the same content view to each.

Library->dev
Library->dev2
Library->dev3
Comment 5 Garik Khachikyan 2013-10-21 07:44:39 EDT
please check following scenario as well:

Library -> env-dev 
Library -> env-test
1. create CV1 and promote to env-dev
2. create CV2 and try to create a changeset to *promote* the *same* enviuronment - UI just shows up all the time with deletion type of the changeset :/
Comment 6 Kedar Bidarkar 2013-10-21 08:55:49 EDT
We are indeed able to promote same CV's to multiple promotion paths.

Satellite-6.0.2-RHEL-6-20131016.0
Comment 7 Justin Sherrill 2013-10-23 17:06:49 EDT
*** Bug 968421 has been marked as a duplicate of this bug. ***
Comment 8 Bryan Kearney 2014-04-24 13:09:49 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:11:12 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.