Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 973774 - Changing environment of a system without the same content view does not work properly.
Changing environment of a system without the same content view does not work ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: Unused
Assigned To: Eric Helms
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 13:10 EDT by Justin Sherrill
Modified: 2014-04-24 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I can change the env and with selecting a different content-view (71.14 KB, image/png)
2013-10-21 05:44 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Justin Sherrill 2013-06-12 13:10:11 EDT
Description of problem:

How reproducible:
always

Steps to Reproduce:
1. Create an environment Dev1 and Dev2
2. Create two content views  View1 and View2
3. Promote View1 to Dev1
4. Promote View2 to Dev2
5. Register a system to Dev1/View1
6. Within the WebUI (System -> details) try to move the system to Dev2/View2
 a) Change its environment to Dev2
 b) change its view to View2


Actual results:
as part of 6a) the old environment is still selected, and the list of views are not refreshed. 

refreshing the pain shows the correct environment with its list of content views.

Expected results:
Dev2 should be selected, and View2 should appear in the list

Additional info:
As part of legacy removal this may be moot, but filing to track the issue.
Comment 1 RHEL Product and Program Management 2013-06-12 14:33:03 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Justin Sherrill 2013-09-20 11:32:38 EDT
So there are still some issues with this page/widget;

Currently it allows me to select any content view even if it does not exist in the selected environment.  An error occurs if i click save, but there is very little indication that the save did not occur other than the save/cancel buttons not going away.
Comment 4 Eric Helms 2013-09-30 13:31:07 EDT
Tracking fix upstream here - https://github.com/Katello/katello/pull/3058
Comment 5 Eric Helms 2013-10-02 13:59:05 EDT
Merged as of - 69d0e435d54f28f1ea8d4648a27adb347001540a

With the introduction of the new systems UI, a tighter connection was added between environment selection and forcing a user to choose a content view. Users should see:

Change environment
 - Content view selection is triggered
 - If the user clicks save, both the environment and content view are updated
 - If the user clicks cancel, both changes are 'reverted'
Comment 8 Sachin Ghai 2013-10-21 05:41:06 EDT
Verified with snap6 compose2 (MDP2)

katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch

I can change the environment of a registered system and by choosing a different content-view. Please see the attachment for verification.
Comment 9 Sachin Ghai 2013-10-21 05:44:31 EDT
Created attachment 814507 [details]
I can change the env and with selecting a different content-view
Comment 10 Bryan Kearney 2014-04-24 13:08:23 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.