Bug 973781 - joystick-support requires non-PAE modules
Summary: joystick-support requires non-PAE modules
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: joystick-support   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bruno Wolff III
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-12 17:42 UTC by Wes Hardaker
Modified: 2013-06-13 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 16:55:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wes Hardaker 2013-06-12 17:42:32 UTC
Description of problem:

The joystick-support module properly requires the kernel-modules-extra, but this doesn't actually work on a PAE based kernel because the kernel-PAE-modules-extra needs to be included instead (or at least too)

Version-Release number of selected component (if applicable):

  3.8.13-100.fc17.i686

How reproducible:

  Easy

Steps to Reproduce:
1. install a PAE based kernel
2. install joystick-support
3. modprobe jsdev
   # which fails

Actual results:

  # modprobe fails with unable to find the module

Expected results:

  # modprobe succeeds and loads the module (and creates /dev/input/js*)

Additional info:

Comment 1 Bruno Wolff III 2013-06-12 18:26:55 UTC
kernel-PAE-modules-extra does provide kernel-modules-extra, so in theory installing joystick-support should be able to grab the correct package.It does pick up the correct one for me. This is also what gfs2-utils does.

Do you have a mix of PAE and non-PAE kernels installed on that machine? Or perhaps the running kernel doesn't match the version of kernel-PAE-modules-extra that was installed?

Comment 2 Wes Hardaker 2013-06-13 04:27:38 UTC
I do have both PAE and non-PAE kernels on the machine.  That might trigger it to only install the non-PAE version of modules-extra?

Comment 3 Bruno Wolff III 2013-06-13 16:55:44 UTC
Right. Just installing one version of kernel(-PAE)?-modules-extra satisfies the dependency. I don't think there is a good way around this. In your case once you install a PAE version that will keep getting updated.

I think this is just a limitation of how the dependency system interacts with being able to have multiple kernels installed.

I'm going to close this, but if you think you have a good idea on how to fix it, you can reopen it. (Though mostly likely a fix would be needed for rpm.)


Note You need to log in before you can comment on or make changes to this bug.