Bug 973786 - pcsd fails to start: "cannot load such file -- rpam_ext (LoadError)"
pcsd fails to start: "cannot load such file -- rpam_ext (LoadError)"
Status: CLOSED DUPLICATE of bug 974759
Product: Fedora
Classification: Fedora
Component: pcs (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Chris Feist
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 14:08 EDT by Andrew Price
Modified: 2013-06-28 15:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 15:35:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Price 2013-06-12 14:08:40 EDT
Description of problem:

pcsd fails to start with error message:

    in `require': cannot load such file -- rpam_ext (LoadError)

Version-Release number of selected component (if applicable):

# rpm -q pcs
pcs-0.9.44-4.fc19.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Install pcs (following the cluster from scratch instructions)
2. Start pcsd

Actual results:

Jun 12 06:35:03 curie-01 pcsd[537]: Starting pcsd: /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- rpam_ext (LoadError)
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45:in `require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/lib/pcsd/gemhome/gems/rpam-ruby19-1.2.1/lib/rpam.rb:1:in `<top (required)>'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:110:in `require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:110:in `rescue in require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:35:in `require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/lib/pcsd/auth.rb:4:in `<top (required)>'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45:in `require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45:in `require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/lib/pcsd/pcsd.rb:11:in `<top (required)>'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45:in `require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:45:in `require'
Jun 12 06:35:03 curie-01 pcsd[537]: from /usr/lib/pcsd/ssl.rb:47:in `<main>'
Jun 12 06:35:03 curie-01 pcsd[537]: [FAILED]
Jun 12 06:35:03 curie-01 systemd[1]: pcsd.service: main process exited, code=exited, status=1/FAILURE
Jun 12 06:35:03 curie-01 systemd[1]: Unit pcsd.service entered failed state.


Expected results:

pcsd starts successfully
Comment 1 Chris Feist 2013-06-28 15:35:22 EDT

*** This bug has been marked as a duplicate of bug 974759 ***

Note You need to log in before you can comment on or make changes to this bug.