Bug 973823 - Nectar's HTTPSCurlDownloader uses ssl_client_certs handed to other downloaders
Summary: Nectar's HTTPSCurlDownloader uses ssl_client_certs handed to other downloaders
Status: CLOSED NOTABUG
Alias: None
Product: Pulp
Classification: Retired
Component: z_other   
(Show other bugs)
Version: Master
Hardware: Unspecified Unspecified
low
high
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: Preethi Thomas
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-12 21:00 UTC by Randy Barlow
Modified: 2014-11-12 02:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-12 02:42:24 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Randy Barlow 2013-06-12 21:00:37 UTC
This is a tough one to track down so far, but if you instantiate two HTTPSCurlDownloaders, giving one an SSL client cert and not giving such a cert to the other, the one that wasn't given the certificate will still use it.

Comment 2 Randy Barlow 2013-06-12 21:10:43 UTC
I noticed that the curl.py file doesn't use the cleanup process described in the libcurl documentation[0]. I'm not sure that's the cause of the problem, but it might be.

[0] http://curl.haxx.se/libcurl/c/curl_multi_cleanup.html

Comment 3 Michael Hrivnak 2013-09-26 19:29:02 UTC
moving this to low priority since nothing is using the curl downloader now

Comment 4 Chris Duryee 2014-11-12 02:42:24 UTC
This downloader was removed from nectar in version 1.1.7.

Closing bug as CLOSED/NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.