Bug 973840 - Cannot access openshift Jboss As 7 app
Cannot access openshift Jboss As 7 app
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 18:42 EDT by Hanine HAMZIOUI ALMADANI
Modified: 2015-05-14 19:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 11:52:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hanine HAMZIOUI ALMADANI 2013-06-12 18:42:58 EDT
Description of problem:

The first June 2013, I pushed mere changes to my app and since then, I couldn't access the app nomore. I deleted the whole app, and recreate a new one from scratch and then pushed again my local app using git over 6 times using the Full Java EE profile, as well as the Jboss As 7 server profile. Same problem. When using mozilla firefox this is what I get:

XML Parsing Error: no element found Location: http://honeybee-otika.rhcloud.com/index.xhtml Line Number 1, Column 1: ^

And when using Chrome: I get: Oops! This link appears to be broken. or : The XML file does not appear to have any style information associated with it. The document tree is shown below.

I checked everything in the code and the database, and everything seems fine. Since in my local machine, it all works fine. I first, created a JBoss as 7 server app and tried but in vain and to confirm, I deleted everything and recreated the app from the JBoss as 7 Full Profile (Kitchensink quickstart), but the same problem happens.

It is a Java EE application using MySQL database (using a datasource MysqlDS, and an authentication realm in JBoss-AS)

Ps: I have another app using the same environment (With PostgreSQL as a difference) and it works fine.

Do you have any clue?

I checked all the XML files in my app and nothing suspicious.
Comment 1 Hanine HAMZIOUI ALMADANI 2013-06-13 11:52:31 EDT
Sorry for the bother.
Problem was resolved modifying the jboss-web.xml file. 
the context root in Openshift JBOSS As, means one has to type the app url + the context root. In a local dev machine, specifying / as context root is not allowed.

Closing this report.

Note You need to log in before you can comment on or make changes to this bug.