This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 973852 - [abrt] targetcli-2.1.fb26-1.fc19: module.pyx:139:kmod.module.Module.insert (kmod/module.c:2289):KmodError: Could not load module
[abrt] targetcli-2.1.fb26-1.fc19: module.pyx:139:kmod.module.Module.insert (k...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: targetcli (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andy Grover
Fedora Extras Quality Assurance
abrt_hash:b57230b973baaef25496dd645ab...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 21:14 EDT by Kurt Miller
Modified: 2013-06-29 14:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: targetcli-2.1.fb26-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 22:02:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.89 KB, text/plain)
2013-06-12 21:14 EDT, Kurt Miller
no flags Details
File: core_backtrace (1.15 KB, text/plain)
2013-06-12 21:14 EDT, Kurt Miller
no flags Details
File: environ (2.96 KB, text/plain)
2013-06-12 21:14 EDT, Kurt Miller
no flags Details

  None (edit)
Description Kurt Miller 2013-06-12 21:14:07 EDT
Description of problem:
executing targetcli failed

Version-Release number of selected component:
targetcli-2.1.fb26-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python /usr/bin/targetcli
dso_list:       python-rtslib-2.1.fb35-1.fc19.noarch
executable:     /usr/bin/targetcli
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
module.pyx:139:kmod.module.Module.insert (kmod/module.c:2289):KmodError: Could not load module

Traceback (most recent call last):
  File "/usr/bin/targetcli", line 88, in <module>
    main()
  File "/usr/bin/targetcli", line 66, in main
    root_node.refresh()
  File "/usr/lib/python2.7/site-packages/targetcli/ui_root.py", line 51, in refresh
    UIBackstores(self)
  File "/usr/lib/python2.7/site-packages/targetcli/ui_backstore.py", line 90, in __init__
    self.refresh()
  File "/usr/lib/python2.7/site-packages/targetcli/ui_backstore.py", line 94, in refresh
    UIPSCSIBackstore(self)
  File "/usr/lib/python2.7/site-packages/targetcli/ui_backstore.py", line 181, in __init__
    UIBackstore.__init__(self, 'pscsi', parent)
  File "/usr/lib/python2.7/site-packages/targetcli/ui_backstore.py", line 108, in __init__
    self.refresh()
  File "/usr/lib/python2.7/site-packages/targetcli/ui_backstore.py", line 112, in refresh
    for so in RTSRoot().storage_objects:
  File "/usr/lib/python2.7/site-packages/rtslib/root.py", line 69, in __init__
    modprobe('target_core_mod')
  File "/usr/lib/python2.7/site-packages/rtslib/utils.py", line 346, in modprobe
    kmod.Kmod().modprobe(module)
  File "kmod.pyx", line 107, in kmod.kmod.Kmod.modprobe (kmod/kmod.c:2413)
  File "module.pyx", line 139, in kmod.module.Module.insert (kmod/module.c:2289)
KmodError: Could not load module

Local variables in innermost frame:
_list: <module 'kmod.list' from '/usr/lib64/python2.7/site-packages/kmod/list.so'>
_collections: <module 'collections' from '/usr/lib64/python2.7/collections.pyc'>
__builtins__: <module '__builtin__' (built-in)>
_KmodError: <class 'kmod.error.KmodError'>
Module: <type 'kmod.module.Module'>
__package__: 'kmod'
__file__: '/usr/lib64/python2.7/site-packages/kmod/module.so'
__test__: {}
_util: <module 'kmod._util' from '/usr/lib64/python2.7/site-packages/kmod/_util.so'>
__name__: 'kmod.module'
__doc__: None
Comment 1 Kurt Miller 2013-06-12 21:14:10 EDT
Created attachment 760368 [details]
File: backtrace
Comment 2 Kurt Miller 2013-06-12 21:14:12 EDT
Created attachment 760369 [details]
File: core_backtrace
Comment 3 Kurt Miller 2013-06-12 21:14:15 EDT
Created attachment 760370 [details]
File: environ
Comment 4 Kurt Miller 2013-06-13 11:48:41 EDT
Some Additional info:
AZUS Z87-Pro Motherboard with i7-4770 processor running 1007 UEFI BIOS (latest release).
lspci -vv output:

04:00.0 Fibre Channel: QLogic Corp. ISP2532-based 8Gb Fibre Channel to PCI Express HBA (rev 02)
        Subsystem: QLogic Corp. Device 015d
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: I/O ports at e100 [size=256]
        Region 1: Memory at f7c84000 (64-bit, non-prefetchable) [size=16K]
        Expansion ROM at f7c40000 [disabled] [size=256K]
        Capabilities: [44] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [4c] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 1024 bytes, PhantFunc 0, Latency L0s <4us, L1 <1us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
                DevCtl: Report errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
                        MaxPayload 128 bytes, MaxReadReq 4096 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 5GT/s, Width x8, ASPM L0s, Latency L0 <512ns, L1 <2us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 5GT/s, Width x4, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Range B, TimeoutDis+, LTR-, OBFF Not Supported
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
                LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance De-emphasis: -6dB
                LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
                         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
        Capabilities: [88] MSI: Enable- Count=1/32 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Capabilities: [98] Vital Product Data
                Product Name: PCI-Express Dual Channel 8Gb Fibre Channel HBA
                Read-only fields:
                        [PN] Part number: QLE2562
                        [SN] Serial number: RFD1104K71315
                        [V0] Vendor specific: PW=15W
                        [MN] Manufacture ID: 50 58 32 38 31 30 34 30 33 2d 32 35 20 20 48
                        [V1] Vendor specific: 02.00
                        [V3] Vendor specific: 04.04.00
                        [V4] Vendor specific: 02.16
                        [V5] Vendor specific: 02.00
                        [YA] Asset tag:                 
                        [RV] Reserved: checksum good, 0 byte(s) reserved
                End
        Capabilities: [a0] MSI-X: Enable+ Count=2 Masked-
                Vector table: BAR=1 offset=00002000
                PBA: BAR=1 offset=00003000
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [138 v1] Power Budgeting <?>
        Kernel driver in use: qla2xxx

04:00.1 Fibre Channel: QLogic Corp. ISP2532-based 8Gb Fibre Channel to PCI Express HBA (rev 02)
        Subsystem: QLogic Corp. Device 015d
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 17
        Region 0: I/O ports at e000 [size=256]
        Region 1: Memory at f7c80000 (64-bit, non-prefetchable) [size=16K]
        Expansion ROM at f7c00000 [disabled] [size=256K]
        Capabilities: [44] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [4c] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 1024 bytes, PhantFunc 0, Latency L0s <4us, L1 <1us
                        ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset+
                DevCtl: Report errors: Correctable+ Non-Fatal+ Fatal+ Unsupported+
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+ FLReset-
                        MaxPayload 128 bytes, MaxReadReq 4096 bytes
                DevSta: CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
                LnkCap: Port #0, Speed 5GT/s, Width x8, ASPM L0s, Latency L0 <512ns, L1 <2us
                        ClockPM- Surprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 5GT/s, Width x4, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Range B, TimeoutDis+, LTR-, OBFF Not Supported
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
                LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
                         EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
        Capabilities: [88] MSI: Enable- Count=1/32 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Capabilities: [98] Vital Product Data
                Product Name: PCI-Express Dual Channel 8Gb Fibre Channel HBA
                Read-only fields:
                        [PN] Part number: QLE2562
                        [SN] Serial number: RFD1104K71315
                        [V0] Vendor specific: PW=15W
                        [MN] Manufacture ID: 50 58 32 38 31 30 34 30 33 2d 32 35 20 20 48
                        [V1] Vendor specific: 02.00
                        [V3] Vendor specific: 04.04.00
                        [V4] Vendor specific: 02.16
                        [V5] Vendor specific: 02.00
                        [YA] Asset tag:                 
                        [RV] Reserved: checksum good, 0 byte(s) reserved
                End
        Capabilities: [a0] MSI-X: Enable+ Count=2 Masked-
                Vector table: BAR=1 offset=00002000
                PBA: BAR=1 offset=00003000
        Capabilities: [100 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
                AERCap: First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
        Capabilities: [138 v1] Power Budgeting <?>
        Kernel driver in use: qla2xxx
Comment 5 Kurt Miller 2013-06-13 12:22:35 EDT
Typo in last comment: Motherboard is *ASUS* Z87-Pro.

Updating QLogic Bios/firmware from 2.12 to 3.20 has corrected this problem for me. Feel free to close the report.
Comment 6 Kurt Miller 2013-06-13 16:21:06 EDT
Ugh. Commented too soon. The problem appears to be intermittent. Please let me know what additional information may be helpful to diagnose this further.
Comment 7 Kurt Miller 2013-06-17 22:55:34 EDT
The first time targetcli is run after boot must be by root otherwise the problem seen in Comment 1 occurs.
Comment 8 Andy Grover 2013-06-18 13:55:04 EDT
ok that's all it is? cool. Working on a fix.
Comment 9 Fedora Update System 2013-06-18 14:39:35 EDT
targetcli-2.1.fb26-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/targetcli-2.1.fb26-2.fc18
Comment 10 Fedora Update System 2013-06-18 14:39:44 EDT
targetcli-2.1.fb26-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/targetcli-2.1.fb26-2.fc19
Comment 11 Kurt Miller 2013-06-18 15:06:57 EDT
(In reply to Andy Grover from comment #8)
> ok that's all it is? cool. Working on a fix.

Initially I believe the old card firmware was the cause. IIRC, I tried to run as root and received the same error. I would need to downgrade the card firmware to confirm that though.

I tried your update. It looks good to me, thanks!

[kurt@tardis ~]$ targetcli
Could not load module
Retry as root.

[kurt@tardis ~]$ sudo targetcli
targetcli shell version 2.1.26
Copyright 2011 by RisingTide Systems LLC and others.
For help on commands, type 'help'.

/> exit
Global pref auto_save_on_exit=true
Last 10 configs saved in /etc/target/backup.
Configuration saved to /etc/target/saveconfig.json

[kurt@tardis ~]$ targetcli
targetcli shell version 2.1.26
Copyright 2011 by RisingTide Systems LLC and others.
For help on commands, type 'help'.

You are not root, disabling privileged commands.

/> exit
Comment 12 Fedora Update System 2013-06-19 00:31:31 EDT
Package targetcli-2.1.fb26-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing targetcli-2.1.fb26-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11215/targetcli-2.1.fb26-2.fc18
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-06-26 22:02:50 EDT
targetcli-2.1.fb26-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-06-29 14:36:56 EDT
targetcli-2.1.fb26-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.