Bug 973860 - Possible Migration Bug(s)
Possible Migration Bug(s)
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 22:39 EDT by xianrenb
Modified: 2015-05-14 19:21 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:16:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xianrenb 2013-06-12 22:39:03 EDT
Description of problem:
There is/are possible migration bug(s) after recent update of OpenShift Online (around June 05 at 03:00 EDT).
(Also mentioned in https://www.openshift.com/forums/openshift/possible-wrong-settings and https://www.openshift.com/forums/openshift/php-problem-could-not-git-push-correctly-after-recent-update-of-openshift-online )
My application URLs are https://myquicknet-xianrenb.rhcloud.com/ and https://lrpost-xianrenb.rhcloud.com/ .

Version-Release number of selected component (if applicable):
PHP 5.3 gear

How reproducible:
unknown for others, but seems not reproducible as reported by Red Hat staff in the above links.

Steps to Reproduce:
"git push"(case1) or "git push -f"(case 2) at the client side.
For case 2, the follow lines are added in the "pre_build" action hook script:
*** lines added(start) ****
pear channel-discover pear.apigen.org
pear channel-discover pear.nette.org
pear channel-discover pear.texy.info
pear channel-discover pear.kukulich.cz
pear channel-discover pear.andrewsville.cz
*** lines added(end) ***
in "deplist.txt", case 1 is "pear.apigen.org/apigen", case 2 is "apigen/ApiGen".

Actual results:
***Case 1(start)***
$ git push
Counting objects: 3, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (2/2), done.
Writing objects: 100% (2/2), 252 bytes, done.
Total 2 (delta 1), reused 0 (delta 0)
remote: CLIENT_MESSAGE: Stopping Apache+mod_php HTTPD server
remote: Waiting for stop to finish
remote: [Mon Jun 10 22:34:49 2013] [warn] module php5_module is already loaded, skipping
remote: Waiting for stop to finish
remote: CLIENT_MESSAGE: `pre-repo-archive' control action not implemented
remote: CLIENT_MESSAGE: `update-configuration' control action not implemented
remote: CLIENT_MESSAGE: `pre-build' control action not implemented
remote: Checking pear: pear.apigen.org/apigen
remote:
remote: Attempting to discover channel "pear.apigen.org"...
remote: downloading channel.xml ...
remote: Starting to download channel.xml (802 bytes)
remote: ....done: 802 bytes
remote: Channel "pear.apigen.org" is not initialized, use "pear channel-discover pear.apigen.org" to initializeor pear config-set auto_discover 1
remote: unknown channel "pear.apigen.org" in "pear.apigen.org/apigen"
remote: invalid package name/package file "pear.apigen.org/apigen"
remote: install failed
remote: An error occurred executing 'gear postreceive'
remote:
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://1786cb06c4314cd4b346e9f0ac47b8d1@myquicknet-xianrenb.rhcloud.com/~/git/myquicknet.git/
   f0b2b4e..30813ec  master -> master
***Case 1(end)***

***Case 2(start)***
$ git push -f
Counting objects: 11, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (5/5), done.
Writing objects: 100% (6/6), 723 bytes, done.
Total 6 (delta 2), reused 0 (delta 0)
remote: CLIENT_MESSAGE: Stopping Apache+mod_php HTTPD server
remote: httpd (no pid file) not running
remote: [Tue Jun 11 21:56:34 2013] [warn] module php5_module is already loaded, skipping
remote: Waiting for stop to finish
remote: Waiting for stop to finish
remote: Waiting for stop to finish
remote: Waiting for stop to finish
remote: Waiting for stop to finish
remote: CLIENT_MESSAGE: `pre-repo-archive' control action not implemented
remote: CLIENT_MESSAGE: `update-configuration' control action not implemented
remote: CLIENT_MESSAGE: `pre-build' control action not implemented
remote: could not create lock file: fopen(/usr/share/pear/.lock): failed to open stream: Permission denied
remote: could not create lock file: fopen(/usr/share/pear/.lock): failed to open stream: Permission denied
remote: could not create lock file: fopen(/usr/share/pear/.lock): failed to open stream: Permission denied
remote: could not create lock file: fopen(/usr/share/pear/.lock): failed to open stream: Permission denied
remote: could not create lock file: fopen(/usr/share/pear/.lock): failed to open stream: Permission denied
remote: An error occurred executing 'gear postreceive'
remote:
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://1786cb06c4314cd4b346e9f0ac47b8d1@myquicknet-xianrenb.rhcloud.com/~/git/myquicknet.git/
   f0b2b4e..1261033  master -> master
***Case 2(end)***

And I noticed that in "~/php/configuration/etc/conf.d/openshift.conf", the setting "include_path" seems incorrect, where "/phplib/pear/pear/php/" is used.

Expected results:
For the above 2 cases, the git push should run correctly with ApiGen installed/updated correctly.

In "~/php/configuration/etc/conf.d/openshift.conf", the setting "include_path" should be "/var/lib/openshift/<user_id>/php/phplib/pear/pear/php/"

Additional info:
I had changed the "include_path" settings to the expected values for my PHP gears by myself on June 10, 2013
Comment 1 Mrunal Patel 2013-06-13 14:11:26 EDT
We have fixed this issue for new apps. Old apps will be migrated soon.
Comment 2 Mrunal Patel 2013-06-13 14:14:15 EDT
For reference - https://bugzilla.redhat.com/show_bug.cgi?id=971822
Comment 3 Mrunal Patel 2013-06-14 11:10:25 EDT

*** This bug has been marked as a duplicate of bug 971822 ***
Comment 4 Dave Neary 2013-06-24 07:04:22 EDT
Hi,

My app has also had multiple serious issues recently - we have no email being sent any more, and the application does not build - no install candidate for pear-Mail is found (pear-Mail is a dependency in deplist.txt)
Comment 5 Andy Grimm 2013-06-28 14:02:45 EDT
The problem here is that pear is not finding $HOME/.pearrc, so the default system-wide configuration of pear, which sets the PEAR directory to /usr/share/pear, is being used.

The "gear" command clears all environment variables and only loads those defined in ~/.env/ files, so when ~/.env/HOME is not present, pear commands do not work.  It appears that the v1->v2 migration did not add .env/HOME to gears.
Comment 6 Mrunal Patel 2013-06-28 17:01:02 EDT
https://github.com/openshift/li/pull/1692

The script fix_home_env.sh must be run to fix gears missing the HOME env var.
Comment 7 Jianwei Hou 2013-07-01 02:56:25 EDT
Verified with https://github.com/openshift/li/pull/1692

Remove the .env/HOME and run the fixing script, the .env/HOME is recreated with correct content, ownership and selinux labels.

Note You need to log in before you can comment on or make changes to this bug.