This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 97391 - missing SSL support in libpq.so.2 on RH9
missing SSL support in libpq.so.2 on RH9
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: postgresql72 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-14 03:11 EDT by Andrei Gaponenko
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-03 11:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrei Gaponenko 2003-06-14 03:11:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The libpq.so.2 compatibility library on RH9 has no SSL support. It did
have it on RH8.  After a RH9 install older applications can no longer
connect to a remote database not accepting clear text connections.


Version-Release number of selected component (if applicable):
postgresql72-1-3

How reproducible:
Always

Steps to Reproduce:
On RH8, postgresql-7.2.3-5.80.src.rpm:

rach ~$ ldd /usr/lib/libpq.so.2
        libssl.so.2 => /lib/libssl.so.2 (0x4002f000)
        libcrypto.so.2 => /lib/libcrypto.so.2 (0x40060000)
        libkrb5.so.3 => /usr/kerberos/lib/libkrb5.so.3 (0x40134000)
        libk5crypto.so.3 => /usr/kerberos/lib/libk5crypto.so.3 (0x40192000)
        libcom_err.so.3 => /usr/kerberos/lib/libcom_err.so.3 (0x401a2000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x401a4000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x401d1000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x401e3000)
        libc.so.6 => /lib/libc.so.6 (0x401f7000)
        libdl.so.2 => /lib/libdl.so.2 (0x40321000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)


On RH9, postgresql72-1-3.src.rpm:

sam ~$ ldd /usr/lib/libpq.so.2
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x4002e000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x4005b000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x4006d000)
        libc.so.6 => /lib/tls/libc.so.6 (0x42000000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)



Actual Results:  An application using libpq.so.2 on RH9 can not connect to a
Postgresql server which requires SSL.


Expected Results:  An application which worked under RH8 should continue working
under RH9.


Additional info:
Comment 1 Andrew Overholt 2003-07-03 11:57:53 EDT
Sorry, this was my fault.  I've built new packages for RHL 9 and they're
available at http://people.redhat.com/~overholt/postgresql72-libs-1-4/ .

Note You need to log in before you can comment on or make changes to this bug.