Bug 973911 - REST allow adding a VM nics with the same mac
REST allow adding a VM nics with the same mac
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.1.4
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Moti Asayag
Martin Pavlik
network
:
: 974116 (view as bug list)
Depends On:
Blocks: 974116
  Show dependency treegraph
 
Reported: 2013-06-13 02:03 EDT by Ilanit Stein
Modified: 2016-02-10 14:53 EST (History)
9 users (show)

See Also:
Fixed In Version: IS14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 974116 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18490 None None None Never

  None (edit)
Description Ilanit Stein 2013-06-13 02:03:01 EDT
Description of problem:
Adding nics to a VM with the same mac should be blocked.
On GUI it is blocked. 

Version-Release number of selected component (if applicable):
si29

Additional info:
1. On 3.2 REST blocks it.
2. This was discovered when the VM was rerun, and failed on: "XML error: Attempted double use of PCI Address '0:0:3.0'"  in vdsm log.
Comment 1 Ilanit Stein 2013-06-13 04:01:44 EDT
Important addition:

The mac of the 2nd nic added, is the same mac, but yet differ in case sensitivity! 
If the exact mac is given to the 2nd nic, including case sensitivity - the nic add fails (that this mac already exists...) 

For example if the mac is:
00:1a:4a:23:a0:db, adding a second nic with mac 00:1a:4a:23:a0:db will fail, but adding a 2nd nic with mac 00:1A:4A:23:A0:DB will succeed.
Comment 2 Ilanit Stein 2013-06-13 09:06:21 EDT
When the nic is added from the GUI, and the mac is the same, but it's case sensitivity is different, The GUI blocks adding this nick, claiming it's the same mac.
If the fix for this bug should be on the network side, and the behaviour is expected to be the same from GUI and REST, then no need for the GUI block.
Comment 4 Simon Grinberg 2013-06-16 09:01:26 EDT
*** Bug 974116 has been marked as a duplicate of this bug. ***
Comment 5 Martin Pavlik 2013-09-12 09:21:13 EDT
verified on is14, adding MAC via REST is not key sensitive 

[RHEVM shell (connected)]# add nic --vm-identifier F19 --name nic4 --plugged True --linked True --mac-address "00:1a:4a:23:a0:db"

id         : 97479acd-14f0-4292-bdf3-51405abb3ecd
name       : nic4
active     : True
interface  : virtio
linked     : True
mac-address: 00:1a:4a:23:a0:db
plugged    : True
vm-id      : 19eac407-63aa-4745-b4df-03ddbdb46cda

[RHEVM shell (connected)]# add nic --vm-identifier F19 --name nic5 --plugged True --linked True --mac-address "00:1A:4A:23:A0:DB"

error: 
status: 409
reason: Conflict
detail: MAC Address is already in use.
Comment 6 Itamar Heim 2014-01-21 17:29:44 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:29:45 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:32:47 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.