Bug 973917 - Update "elementary Icons" to v. 3.0
Update "elementary Icons" to v. 3.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: elementary-icon-theme (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 02:29 EDT by Mattia M.
Modified: 2013-07-23 06:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: elementary-icon-theme-3.0-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 02:03:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattia M. 2013-06-13 02:29:45 EDT
Description of problem:
A new version (3.0) of "elementary Icons" was released some hours ago.
It would be nice if you could update the Fedora package accordingly.


Version-Release number of selected component (if applicable):
elementary-icon-theme-2.7.1-4.*.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

"elementary Icons" 3.0 page on Launchpad: https://launchpad.net/elementaryicons/3.x/3.0

"elementary Icons" 3.0 source: https://launchpad.net/elementaryicons/3.x/3.0/+download/elementary.tar.gz
Comment 1 hannes 2013-06-13 02:33:12 EDT
Wow, that was quick. Will try to find some time over the weekend.
Comment 2 Mattia M. 2013-06-14 03:12:49 EDT
(In reply to hannes from comment #1)
> Wow, that was quick. Will try to find some time over the weekend.

Great, thank you!
Comment 3 hannes 2013-06-15 03:01:12 EDT
Have a look at these packages:
http://hannes.fedorapeople.org/elementary-icon-theme-3.0-1.fc19.noarch.rpm
http://hannes.fedorapeople.org/elementary-icon-theme-3.0-1.fc19.src.rpm

Just install the noarch package and give me some feedback. I already noticed some missing icons, but not sure how to fix it. But mostly it's working.
Comment 4 Mattia M. 2013-06-15 03:28:02 EDT
(In reply to hannes from comment #3)
> Have a look at these packages:
> http://hannes.fedorapeople.org/elementary-icon-theme-3.0-1.fc19.noarch.rpm
> http://hannes.fedorapeople.org/elementary-icon-theme-3.0-1.fc19.src.rpm
> 
> Just install the noarch package and give me some feedback. I already noticed
> some missing icons, but not sure how to fix it. But mostly it's working.

After a quick look at the content of the packages, I think you should remove the ".bzrignore" file and put the "AUTHORS", "CONTRIBUTORS" and "COPYING" files under "/usr/share/doc".
Anyway, I haven't install the package yet.
Comment 5 Mattia M. 2013-06-20 03:09:39 EDT
(In reply to Mattia M. from comment #4)
> After a quick look at the content of the packages, I think you should remove
> the ".bzrignore" file and put the "AUTHORS", "CONTRIBUTORS" and "COPYING"
> files under "/usr/share/doc".

I've tried to modify your .spec file in order to solve the above issues (also, I've corrected the "Source0" field, which was still pointing to the old version of the icon set).
It seems to be working, but I would prefer you to check it anyway.

SPEC: https://dl.dropboxusercontent.com/u/39458594/Fedora%20packages/elementary-icon-theme.spec

SRPM: https://dl.dropboxusercontent.com/u/39458594/Fedora%20packages/elementary-icon-theme-3.0-1.fc19.src.rpm

RPM: https://dl.dropboxusercontent.com/u/39458594/Fedora%20packages/elementary-icon-theme-3.0-1.fc19.noarch.rpm

Let me know what you think.
Comment 6 Mattia M. 2013-06-27 04:41:34 EDT
Any news on the update? Thanks.
Comment 7 hannes 2013-06-27 05:05:21 EDT
Well, the problem is that the theme is not really complete and I have a lot of missing icons under Xfce. So it's not really appropriate to update the package.
I already tried to contact upstream to find a solution.
Comment 8 Mattia M. 2013-06-29 02:24:53 EDT
(In reply to hannes from comment #7)
> Well, the problem is that the theme is not really complete and I have a lot
> of missing icons under Xfce. So it's not really appropriate to update the
> package.
> I already tried to contact upstream to find a solution.

But on Gnome it looks quite complete: I've been using the 3.x version of this icon theme for several months and I've noticed only few missing icons.

As Gnome is the default DE for Fedora, I think it is worth packaging it anyway.
Comment 9 Fedora Admin XMLRPC Client 2013-06-30 04:20:03 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Christopher Meng 2013-06-30 06:04:53 EDT
OK, after a fully investigation I will push an update.
Comment 11 Christopher Meng 2013-06-30 06:05:03 EDT
OK, after a fully investigation I will push an update.
Comment 12 Fedora Update System 2013-07-09 10:13:14 EDT
elementary-icon-theme-3.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/elementary-icon-theme-3.0-1.fc18
Comment 13 Fedora Update System 2013-07-09 10:15:10 EDT
elementary-icon-theme-3.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/elementary-icon-theme-3.0-1.fc19
Comment 14 Fedora Update System 2013-07-09 21:23:57 EDT
Package elementary-icon-theme-3.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing elementary-icon-theme-3.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12657/elementary-icon-theme-3.0-1.fc18
then log in and leave karma (feedback).
Comment 15 Christopher Meng 2013-07-16 01:53:59 EDT
Is this update OK?
Comment 16 Mattia M. 2013-07-16 01:59:06 EDT
(In reply to Christopher Meng from comment #15)
> Is this update OK?

I installed the F19 package and everything looks fine. For me it's OK.
Thank you.
Comment 17 Fedora Update System 2013-07-20 05:42:04 EDT
elementary-icon-theme-3.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-07-20 05:45:10 EDT
elementary-icon-theme-3.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Christoph Wickert 2013-07-22 14:45:05 EDT
(In reply to Christopher Meng from comment #11)
> OK, after a fully investigation I will push an update.

Christoper, what exactly did you investigate?
Comment 20 Christopher Meng 2013-07-22 21:20:09 EDT
(In reply to Christoph Wickert from comment #19)
> (In reply to Christopher Meng from comment #11)
> > OK, after a fully investigation I will push an update.
> 
> Christoper, what exactly did you investigate?

My opinion is that we should first care about GNOME users, and because xfce icons are moved out from upstream, I should have no answers about how to deal with this problem before.

Fortunately, we just find out that a third party project keeps the things:

https://github.com/shimmerproject/elementary-xfce

We need to package a new pkg named elementary-xfce-icon-theme, and Johannes just packaged it.

This is not my problem, one side needs its latest version, another side just want to keep the previous version. :(
Comment 21 Christoph Wickert 2013-07-23 06:39:58 EDT
(In reply to Christopher Meng from comment #20)
> My opinion is that we should first care about GNOME users, 

With all due respect, this is the kind of attitude that has brought Fedora a lot of negative views. And even a lot of GNOME programs will break, not the GNOME 3 core apps but others.

> xfce icons are moved out from upstream

That's why we should not push that change downstream in F18 and F19. You might want to read https://fedoraproject.org/wiki/Updates_Policy#Stable_Releases

> We need to package a new pkg named elementary-xfce-icon-theme, and Johannes
> just packaged it.

We cannot make people install a new package during the lifetime of a stable release but only in a new version.

Anyway, there is no much use in debating here now. Please be more careful next time. Thanks!

Note You need to log in before you can comment on or make changes to this bug.