Bug 973929 - Message after updating custom info for distributor is invalid in cli
Message after updating custom info for distributor is invalid in cli
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.1
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Adam Price
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 03:05 EDT by Tazim Kolhar
Modified: 2014-04-24 13:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-06-13 03:05:32 EDT
Description of problem:

Message after updating custom info for distributor is invalid in cli

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.57.e5613dd.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.90.6c7a175.el6.noarch
katello-cli-common-1.4.2-1.git.90.6c7a175.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.625.68dc9b9.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.2-1.git.625.68dc9b9.el6.noarch
katello-headpin-1.4.2-1.git.625.68dc9b9.el6.noarch
katello-common-1.4.2-1.git.625.68dc9b9.el6.noarch
katello-headpin-all-1.4.2-1.git.625.68dc9b9.el6.noarch
katello-repos-1.4.2-1.el6.noarch

How reproducible:
1.# yum install -y katello-headpin-all
2.# katello-configure --user-pass=****

Steps to Reproduce:

# headpin -u admin -p **** distributor update_custom_info --org ACME_Corporation --name dis_name --keyname testkeyupdate --value testupdatevalue 
Couldn't find custom info with keyname 'testkeyupdate'

# headpin -u admin -p ***** distributor info --name dis_name --org ACME_Corporation
--------------------------------------------------------------------------------
              Distributor Information For Org [ ACME_Corporation ]
--------------------------------------------------------------------------------

Name         : dis_name
UUID         : 40ebcb8e-5911-4428-9d94-eec4e7badbab
Environment  : Library
Created      : 2013/06/13 06:55:25
Last Updated : 2013/06/13 06:55:25
Description:
    Initial Creation Params
Custom Info:
    [ testkey: testupdatevalue ]


Actual results:
The value is updated but the message is invalid 


Expected results:
Successfully updated custom info with keyname 'testkeyupdate'

Additional info:
Comment 1 RHEL Product and Program Management 2013-06-13 03:23:38 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Tazim Kolhar 2013-06-13 03:32:29 EDT
# echo $?
65

The exitcode is 65 however it should be 0
Comment 4 Adam Price 2013-07-31 14:19:36 EDT
https://github.com/Katello/katello-cli/pull/62
Comment 6 Hayk Hovsepyan 2013-10-11 05:03:28 EDT
Verified on revision:
signo-0.0.22-2.el6sat.noarch
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
foreman-1.3.0-15.el6sat.noarch
katello-cli-common-1.4.3-19.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
pulp-nodes-common-2.3.0-0.17.beta.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-0.8.25-1.el6sam.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-pulp-1.4.6-29.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-agent-1.4.4-3.el6sat.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-12.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-qpid-broker-key-pair-1.0-1.noarch
foreman-proxy-1.3.0-3.el6sat.noarch
foreman-postgresql-1.3.0-15.el6sat.noarch
katello-cli-1.4.3-19.el6sat.noarch
pulp-selinux-2.3.0-0.17.beta.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-10.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.17.beta.el6sat.noarch
pulp-nodes-parent-2.3.0-0.17.beta.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
signo-katello-0.0.22-2.el6sat.noarch
katello-glue-candlepin-1.4.6-29.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-1.4.6-29.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
katello-configure-foreman-1.4.5-10.el6sat.noarch
katello-foreman-all-1.4.6-29.el6sat.noarch
Katello-Katello-Configuration-KatelloClient-1.1-53.noarch
candlepin-cert-consumer-ares.usersys.redhat.com-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
katello-configure-1.4.5-10.el6sat.noarch
pulp-server-2.3.0-0.17.beta.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.17.beta.el6sat.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
katello-common-1.4.6-29.el6sat.noarch
katello-glue-elasticsearch-1.4.6-29.el6sat.noarch
katello-all-1.4.6-29.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.3.0-0.17.beta.el6sat.noarch
Katello-Katello-Installation-HammerCLI-1.0-7.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 9 Bryan Kearney 2014-04-24 13:08:49 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.