Bug 973960 - [RHSC] When volumes of the same name are created in different clusters via the Console, choosing one from the System tree lists all of them.
[RHSC] When volumes of the same name are created in different clusters via th...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Kanagaraj
Dustin Tsang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 03:46 EDT by Shruti Sampat
Modified: 2016-04-18 06:06 EDT (History)
9 users (show)

See Also:
Fixed In Version: bb5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (124.89 KB, image/png)
2013-06-13 03:46 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16226 None None None Never

  None (edit)
Description Shruti Sampat 2013-06-13 03:46:03 EDT
Created attachment 760508 [details]
screenshot

Description of problem:
---------------------------------------
When volumes of the same name are created in different clusters, and one of them is selected from the System tree on the left hand-side, all the volumes that share that name are displayed in the flat view.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb3.el6rhs 

How reproducible:
Always

Steps to Reproduce:
1. Create more than one cluster via the Console and add servers to each of them.
2. Create a volume of the same name in the multiple clusters created.
3. From the System tree on the left-hand side, select the volume created from 
   under one of the clusters.

Actual results:
All the volumes that share that name are shown in the flat view on the right-hand side.

Expected results:
Only the selected volume should be displayed.

Additional info:
Comment 2 Dustin Tsang 2013-07-08 14:23:48 EDT
rhsc-bb5: no longer able to create servers with the same name. even though there is no server available.
Comment 3 Scott Haines 2013-09-23 18:25:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.