This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 973966 - [abrt] libreoffice-core-3.5.7.2-12.fc17: __cxxabiv1::__dynamic_cast: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.7.2-12.fc17: __cxxabiv1::__dynamic_cast: Process ...
Status: CLOSED DUPLICATE of bug 987954
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:d4853f38527188097311be719fc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 03:57 EDT by Piotr Nogaś
Modified: 2013-07-24 10:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-20 10:24:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (41.32 KB, text/plain)
2013-06-13 03:57 EDT, Piotr Nogaś
no flags Details

  None (edit)
Description Piotr Nogaś 2013-06-13 03:57:51 EDT
Description of problem:
Just opened powerpoint presentation previously modified in Office 2010 . crash happened during saving my work 

Version-Release number of selected component:
libreoffice-core-3.5.7.2-12.fc17

Additional info:
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --impress file:///home/nogasp1/Documents/Presentations/2013.06.12%20EMC%20SourceOne%20in%202013%20onwards.%20pptx.pptx --splash-pipe=6
crash_function: __cxxabiv1::__dynamic_cast
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.8.13-100.fc17.x86_64
runlevel:       unknown
uid:            1000
ureports_counter: 1
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 __cxxabiv1::__dynamic_cast at ../../../../libstdc++-v3/libsupc++/dyncast.cc:57
 #1 sd::slidesorter::cache::QueueProcessor::ProcessOneRequest at /usr/src/debug/libreoffice-3.5.7.2/sd/source/ui/slidesorter/cache/SlsQueueProcessor.cxx:212
 #2 sd::slidesorter::cache::QueueProcessor::ProcessRequests at /usr/src/debug/libreoffice-3.5.7.2/sd/source/ui/slidesorter/cache/SlsQueueProcessor.cxx:186
 #3 ProcessRequestHdl at /usr/src/debug/libreoffice-3.5.7.2/sd/source/ui/slidesorter/cache/SlsQueueProcessor.cxx:154
 #4 sd::slidesorter::cache::QueueProcessor::LinkStubProcessRequestHdl at /usr/src/debug/libreoffice-3.5.7.2/sd/source/ui/slidesorter/cache/SlsQueueProcessor.cxx:152
 #5 Timer::ImplTimerCallbackProc at /usr/src/debug/libreoffice-3.5.7.2/vcl/source/app/timer.cxx:144
 #6 CallCallback at /usr/src/debug/libreoffice-3.5.7.2/vcl/inc/saltimer.hxx:66
 #7 sal_gtk_timeout_dispatch at /usr/src/debug/libreoffice-3.5.7.2/vcl/unx/gtk/app/gtkdata.cxx:859
 #11 g_main_context_iteration at gmain.c:3207
 #12 GtkData::Yield at /usr/src/debug/libreoffice-3.5.7.2/vcl/unx/gtk/app/gtkdata.cxx:600
Comment 1 Piotr Nogaś 2013-06-13 03:57:58 EDT
Created attachment 760514 [details]
File: backtrace
Comment 2 Caolan McNamara 2013-06-13 06:20:29 EDT
does it always crash if you try and resave the original document ? If so, can you attach it here?
Comment 3 Caolan McNamara 2013-07-24 10:01:38 EDT

*** This bug has been marked as a duplicate of bug 987954 ***

Note You need to log in before you can comment on or make changes to this bug.