Bug 974004 - Unused sql_connection option in ceilometer distribution config
Unused sql_connection option in ceilometer distribution config
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
3.0
Unspecified Unspecified
low Severity low
: beta
: 4.0
Assigned To: Pádraig Brady
Pádraig Brady
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 05:23 EDT by Eoghan Glynn
Modified: 2016-01-04 09:47 EST (History)
3 users (show)

See Also:
Fixed In Version: openstack-ceilometer-2013.2-0.10.1.b3.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:05:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix for review. (678 bytes, patch)
2013-06-13 05:26 EDT, Eoghan Glynn
eglynn: review? (pbrady)
Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Eoghan Glynn 2013-06-13 05:23:07 EDT
Description of problem:

The default storage driver for ceilometer is mongoDB - this will be used in RHOS 3.0 as the alternative sqlalchemy-based driver is not yet considered production-ready.

However /usr/share/ceilometer/ceilometer-dist.conf contains a default setting for the sql_connection config option, which is only relevant to the sqlalchemy driver.

This is unused and could be confusing for users, as it seems to imply that mysql is used to store metering data. 


Version-Release number of selected component (if applicable):

openstack-ceilometer-common-2013.1.2-2.el6ost.noarch


How reproducible:

100%


Steps to Reproduce:
grep -c sql_connection /usr/share/ceilometer/ceilometer-dist.conf


Actual results:
1


Expected results:
0
Comment 1 Eoghan Glynn 2013-06-13 05:26:49 EDT
Created attachment 760537 [details]
Proposed fix for review.
Comment 5 Scott Lewis 2013-11-19 11:54:16 EST
Auto adding >= MODIFIED bugs to beta
Comment 8 Pádraig Brady 2013-12-11 11:42:56 EST
openstack-ceilometer-common-2013.2-4 has

/usr/share/ceilometer/ceilometer-dist.conf:
  [database]
  connection = mongodb://localhost:27017/ceilometer

/etc/ceilometer/ceilometer.conf
  [database]
  # The backend to use for db (string value)
  #backend=sqlalchemy
  # The SQLAlchemy connection string used to connect to the
  # database (string value)
  #connection=mongodb://localhost:27017/ceilometer
Comment 10 errata-xmlrpc 2013-12-19 19:05:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.