Bug 974023 - [RHS-C] "Error: Upgrade failed" while running rhsc-check-update
[RHS-C] "Error: Upgrade failed" while running rhsc-check-update
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Darshan
Prasanth
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 06:02 EDT by Prasanth
Modified: 2015-05-13 12:31 EDT (History)
12 users (show)

See Also:
Fixed In Version: CB2
Doc Type: Bug Fix
Doc Text:
Previously, an error was displayed while running rhsc-check-update command to check for updates. Now, with this update, the rhsc-check-update is obsoleted by engine-upgrade-check command to check for updates. Users with older version of Red Hat Storage Console must update the package to get the new packages of engine-upgrade-check.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:31:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0208 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 07:20:30 EST

  None (edit)
Description Prasanth 2013-06-13 06:02:02 EDT
Description of problem:

Following error is seen while running rhsc-check-update

--------------------
[root@qa-vm13 /]# rhsc-check-update 
Error: Upgrade failed.
please check log at /var/log/ovirt-engine/ovirt-engine-upgrade_2013_06_13_15_28_32.log


[root@qa-vm13 /]# cat /var/log/ovirt-engine/ovirt-engine-upgrade_2013_06_13_15_28_32.log
2013-06-13 15:28:32::DEBUG::common_utils::827::root:: found existing pgpass file /etc/ovirt-engine/.pgpass, fetching DB host value
2013-06-13 15:28:32::DEBUG::common_utils::827::root:: found existing pgpass file /etc/ovirt-engine/.pgpass, fetching DB port value
2013-06-13 15:28:32::DEBUG::common_utils::827::root:: found existing pgpass file /etc/ovirt-engine/.pgpass, fetching DB user value
2013-06-13 15:28:32::DEBUG::common_utils::347::root:: YUM: VERB: Loaded plugins: product-id, rhnplugin, versionlock
2013-06-13 15:28:35::DEBUG::common_utils::347::root:: YUM: VERB: This system is receiving updates from RHN Classic or RHN Satellite.
2013-06-13 15:28:35::DEBUG::common_utils::347::root:: YUM: VERB: Repository JBOSS6.1.0 is listed more than once in the configuration
2013-06-13 15:28:35::DEBUG::common_utils::347::root:: YUM: VERB: Repository JBEAP-6_6.0.1 is listed more than once in the configuration
2013-06-13 15:28:35::DEBUG::common_utils::347::root:: YUM: VERB: Repository rhel-source is listed more than once in the configuration
2013-06-13 15:28:35::DEBUG::common_utils::347::root:: YUM: VERB: Repository rhel-source-beta is listed more than once in the configuration
2013-06-13 15:28:35::INFO::engine-upgrade::1283::root:: Info: /etc/ovirt-engine/.pgpass file found. Continue.
2013-06-13 15:28:35::DEBUG::common_utils::456::root:: Executing command --> '/bin/rpm -q rhevm' in working directory '/'
2013-06-13 15:28:35::DEBUG::common_utils::494::root:: output = package rhevm is not installed

2013-06-13 15:28:35::DEBUG::common_utils::495::root:: stderr = 
2013-06-13 15:28:35::DEBUG::common_utils::496::root:: retcode = 1
2013-06-13 15:28:35::ERROR::engine-upgrade::1523::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine/scripts/engine-upgrade.py", line 1516, in <module>
    main(options)
  File "/usr/share/ovirt-engine/scripts/engine-upgrade.py", line 1286, in main
    if isUpdateFrom30():
  File "/usr/share/ovirt-engine/scripts/engine-upgrade.py", line 937, in isUpdateFrom30
    msg=output_messages.ERR_READ_RPM_VER % "rhevm",
  File "/usr/share/ovirt-engine/scripts/common_utils.py", line 499, in execCmd
    raise Exception(msg)
Exception: Error reading version number for package rhevm
--------------------

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb3.el6rhs 


How reproducible: Always


Steps to Reproduce:
1. Execute rhsc-check-update from the engine
2.
3.

Actual results: rhsc-check-update is failing as it's actually trying to check the update for rhevm version and not rhsc


Expected results: rhsc-upgrade should work as expected
Comment 3 Dusmant 2013-08-12 11:23:44 EDT
Triage : Remove the cmd in Corbett or give a proper error msg
Comment 5 Prasanth 2013-09-18 14:49:01 EDT
"rhsc-check-update" tool was actually working fine in RHS-C 2.0 techpreview1-5, when a newer version is available in the channel. See below:

----------------------
[root@vm11 ~]# rpm -qa|grep rhsc
rhsc-dbscripts-2.0.techpreview1-5.el6rhs.noarch
rhsc-userportal-2.0.techpreview1-5.el6rhs.noarch
rhsc-notification-service-2.0.techpreview1-5.el6rhs.noarch
rhsc-backend-2.0.techpreview1-5.el6rhs.noarch
rhsc-config-2.0.techpreview1-5.el6rhs.noarch
rhsc-jboss-deps-2.0.techpreview1-5.el6rhs.noarch
rhsc-sdk-3.1.0.2-1alpha.el6rhs.noarch
rhsc-webadmin-portal-2.0.techpreview1-5.el6rhs.noarch
rhsc-genericapi-2.0.techpreview1-5.el6rhs.noarch
rhsc-2.0.techpreview1-5.el6rhs.noarch
rhsc-restapi-2.0.techpreview1-5.el6rhs.noarch
rhsc-tools-common-2.0.techpreview1-5.el6rhs.noarch
rhsc-log-collector-2.0-1.el6rhs.noarch
rhsc-setup-2.0.techpreview1-5.el6rhs.noarch


[root@vm11 ~]# rhn-channel -l
jbappplatform-6-x86_64-server-6-rpm
rhel-x86_64-server-6
rhel-x86_64-server-6-rhs-rhsc-2.0
rhel-x86_64-server-6-rhs-rhsc-2.1

[root@vm11 ~]# rhsc-check-update 
Loaded plugins: product-id, rhnplugin, versionlock
This system is receiving updates from RHN Classic or RHN Satellite.
Checking for updates... (This may take several minutes)
7 Updates available:
 * rhsc-2.1.0-0.bb10.el6rhs.noarch
 * rhsc-backend-2.1.0-0.bb10.el6rhs.noarch
 * rhsc-dbscripts-2.1.0-0.bb10.el6rhs.noarch
 * rhsc-log-collector-2.1-0.1.el6rhs.noarch
 * rhsc-restapi-2.1.0-0.bb10.el6rhs.noarch
 * rhsc-setup-2.1.0-0.bb10.el6rhs.noarch
 * rhsc-webadmin-portal-2.1.0-0.bb10.el6rhs.noarch
----------------------

So not sure what recent changes had broken the tool in RHS-C 2.1,
Comment 6 Scott Haines 2013-09-23 19:34:57 EDT
Targeting for 2.1.z U2 (Corbett) release.
Comment 7 Sahina Bose 2013-10-07 07:33:22 EDT
Darshan,
I'm reassigning to you as you were looking into this.
Comment 8 Darshan 2013-10-09 03:07:27 EDT
This issue is fixed in the build CB2. rhsc-check-update command is obsoleted by engine-upgrade-check in this version.

Fix:
   Add the repo for CB2, run yum update. This will update the package rhsc-setup where the issue is fixed. Now engine-upgrade-check command will work as expected.
Comment 9 Prasanth 2013-10-10 04:32:50 EDT
Verified.

[root@vm09 ]# rhsc-check-update 
rhsc-check-update is obsoleted by engine-upgrade-check.
please run engine-upgrade-check for upgrading product or update settings.


[root@vm09 ]# engine-upgrade-check 
VERB: queue package rhsc-setup for update
VERB: package rhsc-setup queued
VERB: Building transaction
VERB: Transaction built
VERB: Transaction Summary:
VERB:     updated    - rhsc-lib-2.1.1-0.0.2.master.el6ev.noarch
VERB:     update     - rhsc-lib-2.1.1-0.0.3.master.el6ev.noarch
VERB:     updated    - rhsc-setup-2.1.1-0.0.2.master.el6ev.noarch
VERB:     update     - rhsc-setup-2.1.1-0.0.3.master.el6ev.noarch
Upgrade available
Comment 10 Shalaka 2014-01-06 05:25:02 EST
Please review the edited DocText and confirm.
Comment 12 errata-xmlrpc 2014-02-25 02:31:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.