Bug 974058 - qcow2 images size reported by glance should match the virtual image size [NEEDINFO]
qcow2 images size reported by glance should match the virtual image size
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity low
: async
: 5.0 (RHEL 7)
Assigned To: Flavio Percoco
Giulio Fidente
:
Depends On: 1048174
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 07:10 EDT by Giulio Fidente
Modified: 2016-04-26 11:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 03:22:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
slong: needinfo? (fpercoco)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1190559 None None None Never

  None (edit)
Description Giulio Fidente 2013-06-13 07:10:35 EDT
Description of problem:
the image size of qcow2 images should match the virtual size reported by qemu-img not the actual data size

# glance image-show ff8f8fb3-76a3-47c0-bfc2-7bbbb9e46950
[...]
| size | 699592704 |
[...]

# qemu-img info /var/lib/glance/images/ff8f8fb3-76a3-47c0-bfc2-7bbbb9e46950
image: /var/lib/glance/images/ff8f8fb3-76a3-47c0-bfc2-7bbbb9e46950
file format: qcow2
virtual size: 6.0G (6442450944 bytes)
disk size: 667M
cluster_size: 65536


Version-Release number of selected component (if applicable):
openstack-glance-2013.1.2-1.el6ost.noarch
Comment 1 John Bresnahan 2013-06-24 15:47:37 EDT
The right fix for this is dependent upon more complicated work that is underway for havana.  There is an import/export effort in which incoming images can be verified/converted as opposed to just uploaded.  This is a very good place to verify things like the image size.  This is also coupled with the async workers blueprint: https://blueprints.launchpad.net/glance/+spec/async-glance-workers.
Comment 2 Flavio Percoco 2013-11-29 05:24:04 EST
Also, I'd argue that using the size field is the right thing to do. The size is also important to know what the file size is. For example, using the image size instead of the file size would break all features that rely on that (Progress bar, for example).

It may be necessary to explicitly differentiate the image_size from the file_size, which in many cases will be the same.
Comment 3 Flavio Percoco 2013-12-13 04:34:24 EST
This will be fixed as part of this blueprint:

https://blueprints.launchpad.net/glance/+spec/split-image-size
Comment 4 Flavio Percoco 2014-01-15 03:22:54 EST
I'm closing this as WONTFIX because the image size won't match the virtual_size. Instead, the proposed blueprint will add a new virtual_size attribute that will hold this information.
Comment 5 Summer Long 2014-07-23 00:25:12 EDT
Flavio, I'm moving requires_doc_text to - since nothing was done. Unless you you want to set it as a Known Issue with text? Is there a specific user problem that you'd like to point out? (Release notes are regenerated with each maintenance release if you want to include info.)

Note You need to log in before you can comment on or make changes to this bug.