Bug 974063 - Ignore Google documents without a thumbnail URI
Summary: Ignore Google documents without a thumbnail URI
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gjs (Show other bugs)
(Show other bugs)
Version: 19
Hardware: x86_64 Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:da5c3ff761d75be9d681e3e1e70...
Keywords:
Depends On:
Blocks: F19-accepted, F19FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-06-13 11:13 UTC by Jiri Eischmann
Modified: 2013-06-18 06:10 UTC (History)
6 users (show)

Fixed In Version: gnome-documents-3.8.3.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 06:10:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (237.40 KB, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: core_backtrace (7.07 KB, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: dso_list (21.66 KB, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: environ (1.53 KB, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: maps (95.35 KB, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: open_fds (3.66 KB, text/plain)
2013-06-13 11:13 UTC, Jiri Eischmann
no flags Details
File: proc_pid_status (934 bytes, text/plain)
2013-06-13 11:14 UTC, Jiri Eischmann
no flags Details
File: var_log_messages (310 bytes, text/plain)
2013-06-13 11:14 UTC, Jiri Eischmann
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 701957 None None None Never

Description Jiri Eischmann 2013-06-13 11:13:27 UTC
Description of problem:
Having a few dozen local documents and connected to Google Docs in GNOME Documents. GNOME Documents is unresponsive or crashes almost immediatelly after startup and while doing random actions.

Version-Release number of selected component:
gjs-1.36.1-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/bin/gjs-console -I /usr/share/gnome-documents/js -c 'const Main = imports.main; Main.start();'
crash_function: append_query_headers
executable:     /usr/bin/gjs-console
kernel:         3.9.4-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 append_query_headers at gdata/services/documents/gdata-documents-service.c:307
 #5 gdata_download_stream_constructor at gdata/gdata-download-stream.c:362
 #7 object_instance_init at gi/object.c:1214
 #8 init_func at gi/object.c:1771
 #9 CallJSNative at jscntxtinlines.h:701
 #10 js::Invoke at jsinterp.cpp:703
 #11 js::ExternalInvoke at jsinterp.cpp:863
 #12 JS_CallFunctionValue at jsapi.cpp:5145
 #13 gjs_call_function_value at gjs/jsapi-util.c:715
 #14 gjs_object_instance_constructor at gi/object.c:1287

Comment 1 Jiri Eischmann 2013-06-13 11:13:32 UTC
Created attachment 760606 [details]
File: backtrace

Comment 2 Jiri Eischmann 2013-06-13 11:13:36 UTC
Created attachment 760607 [details]
File: cgroup

Comment 3 Jiri Eischmann 2013-06-13 11:13:39 UTC
Created attachment 760608 [details]
File: core_backtrace

Comment 4 Jiri Eischmann 2013-06-13 11:13:42 UTC
Created attachment 760609 [details]
File: dso_list

Comment 5 Jiri Eischmann 2013-06-13 11:13:46 UTC
Created attachment 760610 [details]
File: environ

Comment 6 Jiri Eischmann 2013-06-13 11:13:50 UTC
Created attachment 760611 [details]
File: limits

Comment 7 Jiri Eischmann 2013-06-13 11:13:53 UTC
Created attachment 760612 [details]
File: maps

Comment 8 Jiri Eischmann 2013-06-13 11:13:57 UTC
Created attachment 760613 [details]
File: open_fds

Comment 9 Jiri Eischmann 2013-06-13 11:14:00 UTC
Created attachment 760614 [details]
File: proc_pid_status

Comment 10 Jiri Eischmann 2013-06-13 11:14:03 UTC
Created attachment 760615 [details]
File: var_log_messages

Comment 11 Jiri Eischmann 2013-06-13 11:22:54 UTC
I've reproduced this on two different computers. Proposing as a final blocker because it affects basic functionality in one of default apps.

Comment 12 Debarshi Ray 2013-06-14 13:22:15 UTC
Please see the upstream bug for instructions on how to help debugging this. Thanks!

Comment 13 Fedora Update System 2013-06-14 16:21:18 UTC
gnome-documents-3.8.3.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-documents-3.8.3.1-1.fc19

Comment 14 Fedora Update System 2013-06-15 17:06:22 UTC
Package gnome-documents-3.8.3.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-documents-3.8.3.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10909/gnome-documents-3.8.3.1-1.fc19
then log in and leave karma (feedback).

Comment 15 Jiri Eischmann 2013-06-17 15:45:17 UTC
The app doesn't freeze any more, so the bug seems to be fixed, but the initial indexing is still somehow broken because it never stops. It seems to index certain files extremely slowly. I've been running the app for last two hours, there are just a few dozen documents and it's still indexing. I'm hesitating to give it a + karma.

Comment 16 Adam Williamson 2013-06-17 16:56:07 UTC
Discussed at 2013-06-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-06-17/f19final-blocker-review-6.2013-06-17-16.01.log.txt . Given our understanding of the impact (affects only those with docs in a Google Docs account and who have set up their Google account via gnome-online-accounts, and may only affect certain docs), we rejected this as a blocker, we think this is beyond 'basic functionality test'. But accepted as a freeze exception issue as it's a crasher in a stock app on the lives.

Comment 17 Fedora Update System 2013-06-18 06:10:42 UTC
gnome-documents-3.8.3.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.