Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 974075 - SAP 5.10: sblim-cmpi-base: wrong UserModeTime and KernelModeTime
SAP 5.10: sblim-cmpi-base: wrong UserModeTime and KernelModeTime
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sblim (Show other bugs)
5.10
x86_64 Linux
high Severity high
: rc
: 5.11
Assigned To: Vitezslav Crhonek
Alois Mahdal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 07:45 EDT by Henning Sackewitz
Modified: 2016-08-08 09:15 EDT (History)
9 users (show)

See Also:
Fixed In Version: sblim-1-50.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 974071
Environment:
Last Closed: 2014-09-15 20:31:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1201 normal SHIPPED_LIVE sblim bug fix update 2014-09-16 00:17:00 EDT

  None (edit)
Description Henning Sackewitz 2013-06-13 07:45:27 EDT
+++ This bug was initially created as a clone of Bug #974071 +++

The values for UserModeTime and KernelModeTime in CIM class Linux_UnixProcess are incorrectly calculated.

OSBase_UnixProcess.c:

231 if ( (fpstat=fopen(cmd,"r")) != NULL ) {
232 fscanf(fpstat,"%s %s %s %s %s %s %s %s %s %s %s %s %s %s "
233 "%lld %lld %s %s %s %s %s %ld",
234 &umtime,&kmtime,&ctime );
235 fclose(fpstat);
236 (sptr)->kmtime = kmtime10;
237 (sptr)->umtime = umtime*10;

The code is scanning fields 15 and 16 from /proc/[pid]/stat but it should use fields 14 and 15 on current Linux kernels as documented in
/usr/src/linux/Documentation/filesystems/proc.txt.

As a result, KernelModeTime is used for UserModeTime, and Child User Time for KernelModeTime.

See https://sourceforge.net/p/sblim/bugs/2644/ for upstream bug fix.
Comment 1 Frank Danapfel 2014-01-08 02:34:00 EST
Removed RFE from title since this is really a bugfix and not a feature request
Comment 2 Luca Miccini 2014-01-28 10:34:03 EST
On behalf of SAP LinuxLab I confirm that there will be the necessary commitment to test the new packages.  
Luca Miccini
Red Hat partner TAM @ SAP LinuxLAB
Comment 5 RHEL Product and Program Management 2014-01-29 07:08:47 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 11 errata-xmlrpc 2014-09-15 20:31:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1201.html

Note You need to log in before you can comment on or make changes to this bug.