Bug 974135 - Can't sign into sample-portal container
Can't sign into sample-portal container
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER05
: 6.1.0
Assigned To: Peter Palaga
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 09:45 EDT by Filip Kiss
Modified: 2013-11-07 09:21 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: PortalSetupService had a bug when working with multiple containers at same time and there was a configuration missing in sample-portal. Consequence: root user could not sign in into sample-portal container, although one has set the root password using the web form shown on the first request after the installation. Note that this problem has not occurred when the root password was set using bin/setup-portal.sh script before the first start of the portal. Fix: In Portal, the PortalSetupService was fixed to work with multiple containers and the missing configuration was added to sample portal. Result: Now, the root password initialization is shown for every portal container separately and root user can sign in into all portal containers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 09:21:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GTNPORTAL-3188 Major Resolved Allow PortalSetupService to work in multiple portal containers 2013-12-03 03:30:08 EST

  None (edit)
Description Filip Kiss 2013-06-13 09:45:28 EDT
Description of problem:
Can't sign into gatein-sample-portal container.

Steps to Reproduce:
1. set up datasources and security domain in standalone.xml for sample-portal
2. deploy sample-portal container extension quickstart to the portal
3. open sample-portal, try to sign in as root:gtn

Actual results:
can't sign into sample-portal

Expected results:
Sign In with "root" and "gtn" password should work.
Comment 1 Peter Palaga 2013-06-18 11:41:19 EDT
Filip did not know that there are no default users in JPP 6.1. He did not set root password before he experienced the described behavior. The "Try Portal with one of these User Accounts" were removed for JPP 6.1 ER02, see https://issues.jboss.org/browse/GTNPORTAL-3111
Comment 2 Filip Kiss 2013-07-16 11:34:38 EDT
I set root password, opened sample-portal, tried to log in with root + password set from beginning - "Failed to log in" message is displayed.

Build ID: ER02
Comment 4 Peter Palaga 2013-07-17 12:56:17 EDT
There are two ways how root password can be set: 
(1) using bin/setup-portal.sh before the first start of the portal or 
(2) using the form that appears automatically on when accessing an uninitialized portal

I can confirm that the bug occurs with (2) but does not occur with (1). 

I tried to fix through comparing gatein-portal/web/portal/src/main/webapp/WEB-INF/web.xml with gatein-sample-portal/war/src/main/webapp/WEB-INF/web.xml
Recently, there were some filters and servlets added to the default portal's web.xml that -- as I supposed -- could solve the problem when added to sample portal's web.xml. But it did not help.

Leaving open and I'll try to solve it later.
Comment 5 Lucas Ponce 2013-07-18 10:58:31 EDT
PortalSetupService had a bug when working with multiple containers at same time.

Also quickstart-sample-portal had missing configuration for PortalSetupService.

PRs sent to gatein-portal and gatein-portal-quickstarts to fix it.

Take note that:
- sample-porta.ear creates a new portal container with their own database for JCR and IDM.
- so, in this context each portal (portal and sample-portal) are independents.
- setting root password using bin/setup-portal.sh modify root password for all portal containers deployed.
- setting root password by form only set up the password for the current portal container.
- so, a expected behaviour using form to set up root password will be that they have to set up root password of portal "portal" and root password of portal "sample-portal", as they are two different users in two different portal containers (with separate databases for JCR and IDM).
Comment 6 Filip Kiss 2013-08-13 04:09:33 EDT
I was able to log in sample-portal as root, when setting root password using bin/portal-setup.sh
When I tried to set root password using form, there was no "Set up root password" form when accessing sample-portal for the first time (there was form only when accessing default portal for the first time).


Build ID: ER04
Comment 7 Lucas Ponce 2013-08-19 03:39:50 EDT
There is a pending PR to fix this issue:

https://github.com/gatein/gatein-portal-quickstart/pull/23
Comment 8 Peter Palaga 2013-08-19 05:10:01 EDT
Oh, sorry, I thought, I have included the PR from Lucas in ER04 already. That is my mistake. Sorry again. I'll merge it ASAP.
Comment 9 Peter Palaga 2013-08-23 11:03:39 EDT
I can confirm, that the solution of Lucas works with the upcomming JPP 6.1.1.ER05. Someone might find it strange that he needs to initialize the root password twice (once of every portal container) but this is just a consequence of using distinct datasources for the two portals.
Comment 10 Filip Kiss 2013-10-04 10:42:57 EDT
I wasn't able to verify it with prod-qs on ER05 (BZ 1007391). Signing problem has been fixed, but when user is logged in portal, there is GateIn skin. JPP default skin is available only for sample-portal. Tested on CR03.
Comment 14 Filip Kiss 2013-10-10 05:46:39 EDT
I've created new BZ 1016603 for skin problem. Changing to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.