Bug 974164 - firefox won't build
firefox won't build
Status: CLOSED DUPLICATE of bug 919061
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.4
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Red Hat Gecko Maintainer
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 10:35 EDT by Aleš Mareček
Modified: 2013-06-13 14:21 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 14:21:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleš Mareček 2013-06-13 10:35:27 EDT
Description of problem:

Firefox won't build on x86_64, ppc64, (not tested on s390x).



Version-Release number of selected component (if applicable):
firefox-17.0.6-1.el6_4

How reproducible:
Always

Steps to Reproduce:
1. Download source package of Firefox, install dependencies (yum-builddep) and install source package
2. rpmbuild -ba <patch_to_spec_dir>/firefox.spec (~/rpmbuild/SPECS/firefox.spec)


Actual results:
OSError: Command /root/rpmbuild/BUILD...ualenv/bin/python2.6 -c "#!python
\"\"\"Bootstra...sys.argv[1:])






" /root/rpmbuild/BUILD...ols-0.6c11-py2.6.egg failed with error code 1
Populating Python virtualenv
'import site' failed; use -v for traceback
'import site' failed; use -v for traceback
Traceback (most recent call last):
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/python/simplejson-2.1.1/setup.py", line 10, in <module>
    from setuptools import setup, find_packages, Extension, Feature
  File "/usr/lib/python2.6/site-packages/setuptools/__init__.py", line 2, in <module>
    from setuptools.extension import Extension, Library
  File "/usr/lib/python2.6/site-packages/setuptools/extension.py", line 2, in <module>
    from setuptools.dist import _get_unpatched
  File "/usr/lib/python2.6/site-packages/setuptools/dist.py", line 6, in <module>
    from setuptools.command.install import install
  File "/usr/lib/python2.6/site-packages/setuptools/command/install.py", line 2, in <module>
    from distutils.command.install import install as _install
  File "/usr/lib64/python2.6/distutils/command/install.py", line 21, in <module>
    from site import USER_BASE
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/_virtualenv/lib64/python2.6/site.py", line 682, in <module>
    main()
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/_virtualenv/lib64/python2.6/site.py", line 665, in main
    paths_in_sys = virtual_addsitepackages(paths_in_sys)
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/_virtualenv/lib64/python2.6/site.py", line 623, in virtual_addsitepackages
    return addsitepackages(known_paths, sys_prefix=sys.real_prefix)
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/_virtualenv/lib64/python2.6/site.py", line 278, in addsitepackages
    addsitedir(sitedir, known_paths)
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/_virtualenv/lib64/python2.6/site.py", line 203, in addsitedir
    addpackage(sitedir, name, known_paths)
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/_virtualenv/lib64/python2.6/site.py", line 172, in addpackage
    exec(line)
  File "<string>", line 1, in <module>
ImportError: No module named abrt_exception_handler
Traceback (most recent call last):
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/build/virtualenv/populate_virtualenv.py", line 69, in <module>
    populate_virtualenv(sys.argv[1], sys.argv[2])
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/build/virtualenv/populate_virtualenv.py", line 42, in populate_virtualenv
    package[2:])
  File "/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/build/virtualenv/populate_virtualenv.py", line 63, in call_setup
    raise Exception('Error installing package: %s' % directory)
Exception: Error installing package: /root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/python/simplejson-2.1.1
*** Fix above errors and then restart with               "make -f client.mk build"
make[2]: *** [configure] Error 1
make[2]: Leaving directory `/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17'
make[1]: *** [/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17/Makefile] Error 2
make[1]: Leaving directory `/root/rpmbuild/BUILD/firefox-17.0.6/mozilla-esr17'
make: *** [build] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.oDDGrL (%build)


Expected results:
Build without errors.

Additional info:
Comment 1 Tomas Pelka 2013-06-13 14:21:39 EDT

*** This bug has been marked as a duplicate of bug 919061 ***

Note You need to log in before you can comment on or make changes to this bug.