Bug 974176 - softupd creates zombie yumex processes
softupd creates zombie yumex processes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-applet-softupd (Show other bugs)
18
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Patrick Monnerat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 11:06 EDT by Francois Cartegnie
Modified: 2013-07-02 21:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-applet-softupd-0.2.8-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 21:57:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francois Cartegnie 2013-06-13 11:06:04 EDT
Version-Release number of selected component (if applicable):

mate-applet-softupd-0.2.7-1.fc18.x86_64

How reproducible:

Use applet...

Actual results:

yumex zombie processes

Additional info:

No wait handler: ignores manual SIGCHLD.
Comment 1 Patrick Monnerat 2013-06-17 05:34:01 EDT
Thanks for your bug report.
Problem is confirmed and upstream is working on it.
The next upstream version will fix it.
Comment 2 Assen Totin 2013-06-22 17:01:09 EDT
Hi,

Thanks for the report - clearly a miss when the code was initially released (as an old-fashioned guy I use the applet only to notify me, but always update via console yum, hence have not spotted this - but I also do other odd things, so dont't take me as a role model).

Fixed in 0.2.8 available here: 
http://www.zavedil.com/wp-content/uploads/2013/06/mate-applet-softupd-0.2.8.tar.gz

Works for me: when the GUI installer is exited, the child is wait()-ed for. This happens ones each 10 seconds, so a zombie, if spotted at all, should be gone in 10 seconds. 

WWell,
Comment 3 Wolfgang Ulbrich 2013-06-22 17:18:49 EDT
Hi Assen,
thanks for the fix.
Same happens if i called yumex from mintmenu (in repos).
Will do a diff to see what you've done.
Maybe it helps me for mintmenu too.
Comment 4 Fedora Update System 2013-06-24 06:10:24 EDT
mate-applet-softupd-0.2.8-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-applet-softupd-0.2.8-1.fc18
Comment 5 Fedora Update System 2013-06-24 06:10:37 EDT
mate-applet-softupd-0.2.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-applet-softupd-0.2.8-1.fc19
Comment 6 Fedora Update System 2013-06-24 07:05:51 EDT
mate-applet-softupd-0.2.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-applet-softupd-0.2.8-1.fc17
Comment 7 Fedora Update System 2013-06-24 14:51:05 EDT
Package mate-applet-softupd-0.2.8-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-applet-softupd-0.2.8-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11610/mate-applet-softupd-0.2.8-1.fc19
then log in and leave karma (feedback).
Comment 8 Francois Cartegnie 2013-06-25 08:18:15 EDT
Seems fixed in mate-applet-softupd-0.2.8-1.fc18
Can't test 17/19
Comment 9 Fedora Update System 2013-06-26 21:57:47 EDT
mate-applet-softupd-0.2.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-07-02 21:34:57 EDT
mate-applet-softupd-0.2.8-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-07-02 21:43:37 EDT
mate-applet-softupd-0.2.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.