Bug 974184 - dummy oracle jar jar under rhqhome/modules/org/rhq/oralce/
dummy oracle jar jar under rhqhome/modules/org/rhq/oralce/
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Installer (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 11:16 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 08:39:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-06-13 11:16:46 EDT
Description of problem:
dummy oracle jar jar under rhqhome/modules/org/rhq/oralce/

Version-Release number of selected component (if applicable):
master build 741

How reproducible:
always
Comment 1 Heiko W. Rupp 2013-07-02 07:00:31 EDT
What is the issue here? That dummy is required by the system in order to fulfill all dependencies. If the user is using Postgres, this module is fine and just sits there.
If she is using Oracle, she needs to copy the real driver into this place (for a fresh install) or have the rhqctl --upgrade command do that.
Comment 2 Armine Hovsepyan 2013-07-02 08:39:48 EDT
Hi Heiko,

Thanks for your message. I was expecting real oracle jar as it was for previous versions. 

Closing a not a bug.
Comment 3 Heiko W. Rupp 2013-07-02 09:06:46 EDT
Armine,

(just for clarification)

RHQ can not ship with the real Oracle driver for licensing reasons.
JON can ship with the real driver and this is what JON does.

In any case if the dummy driver is in the download and the installer finds a previous real driver (on upgrade), it will copy it over so that it can be used

Note You need to log in before you can comment on or make changes to this bug.