Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 974205 - Cannot delete cloned channels using XMLRPC API
Summary: Cannot delete cloned channels using XMLRPC API
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API
Version: 550
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-13 16:27 UTC by Stephen Benjamin
Modified: 2013-06-19 07:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-19 07:54:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stephen Benjamin 2013-06-13 16:27:18 UTC
Description of problem:

Cannot delete a channel clone of a Red Hat channel using channel.software.delete

Version-Release number of selected component (if applicable):

5.5

How reproducible:

Always

Steps to Reproduce:
1. Clone a Red Hat channel
2. Attempt to delete clone with API channel.software.delete call


Actual results:

xmlrpclib.Fault: <Fault -1: 'redstone.xmlrpc.XmlRpcFault: unhandled internal exception: Red Hat Channels cannot be deleted, only custom channels can.'>

Expected results:

Channel is deleted.

Additional info:

Works fine in the Satellite GUI to delete a cloned channel.

Comment 1 Jan Dobes 2013-06-19 06:14:56 UTC
I'm unable to reproduce this problem. Cloned Red Hat channels are properly deleted using API. Can you please provide more information - how have you cloned this channel, what Red Hat channel it is, source code example?

Comment 2 Stephen Benjamin 2013-06-19 07:54:25 UTC
Sorry, PEBKAC.  All works as expected.

I was passing the original channel label to sat.channel.software.delete instead of the new cloned one.


Note You need to log in before you can comment on or make changes to this bug.