Bug 974217 - 5.4.1 to 5.5 "CREATE UNIQUE INDEX rhn_ram_sid_uq" schema upgrade failure on RHEL 5.9
5.4.1 to 5.5 "CREATE UNIQUE INDEX rhn_ram_sid_uq" schema upgrade failure on R...
Status: CLOSED DUPLICATE of bug 967881
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades (Show other bugs)
541
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 13:26 EDT by Wesley Duffee-Braun
Modified: 2013-06-13 13:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 13:35:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Duffee-Braun 2013-06-13 13:26:38 EDT
Description of problem:
Trying to upgrade from 5.4.1 to 5.5 (disconnected) on RHEL 5.9 x86_64 (fully updated) and the schema upgrade fails with the following error:

DROP INDEX rhn_ram_sid_idx
Error at line 1: 
ORA-01418: specified index does not exist

Version-Release number of selected component (if applicable):
Satellite 5.4.1

Actual results:
Upgrade fails

Expected results:
Upgrade continues

Additional info:
Patch from 
https://git.fedorahosted.org/cgit/spacewalk.git/commit/?id=99317e6fdf60d950277842e7818fb46f9a8e0ca0

-CREATE UNIQUE INDEX rhn_ram_sid_uq
-    ON rhnRam (server_id)
-    TABLESPACE [[4m_tbs]]
-    NOLOGGING;
+declare
+	name_already_used exception;
+	pragma exception_init(name_already_used, -00955);
+begin
+	execute immediate 'create unique index rhn_ram_sid_uq on rhnRam(server_id) tablespace [[4m_tbs]] nologging';
+	dbms_output.put_line('Index rhn_ram_sid_uq successfully created.');
+exception
+	when name_already_used then
+		dbms_output.put_line('Index rhn_ram_sid_uq already exists.');
+end;
+/

Seems to be satisfactory to solving problem.
Comment 2 Milan Zazrivec 2013-06-13 13:35:32 EDT

*** This bug has been marked as a duplicate of bug 967881 ***

Note You need to log in before you can comment on or make changes to this bug.