Bug 97423 - All files ifcfg-eth0 are the same file (hardlink) in all profiles
All files ifcfg-eth0 are the same file (hardlink) in all profiles
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-15 06:40 EDT by Oliver Seidel
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-16 07:13:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Seidel 2003-06-15 06:40:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
if You create a profile Foo and a Profile bar with neat, then you can't creat a ifcfg-eth0 for foo with uses dhcp and a  ifcfg-eth0 for bar that uses a static IP-adress. 
If you create first the foo-profile then you can use dhcp. Than you create the bar-profile. Than you can use the far-profile with the static IP-Adress.
But the foo-profile use now also the static IP-Adress. If i Change the foo-profile back to dhcp, the bar-profile uses also dhcp.
The reason for this Problem is maybe that all profiles uses the same hardlink at all time.

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.0-2

How reproducible:
Always

Steps to Reproduce:
1. Creat profile foo for dhcp
2. Creat profile bar for a static ip-Adress
3. start the device eth0. (You youse now the static IP-Adress from bar)
4. Shutdown eth0 and swicht with neat to profile foo
5. start eth0.  (You youse now the static IP-Adress from bar not the dhcp from foo)
6. change the Properties from foo to dhcp
7. start eth0 (You use now dhcp)
8. Shutdown eth0 and swicht with neat to profile bar
9. start eth0. (now you use in profile bar also dhcp)
    

Additional info:
Comment 1 Harald Hoyer 2003-06-16 07:13:55 EDT
How to use profiles:
http://people.redhat.com/harald/redhat-config-network/help/network-profiles.html
Comment 2 Sergey V. Udaltsov 2003-11-11 15:39:23 EST
I just taken Fedora, create devices eth0_dhcp and eth0_home (poiting
to same eth0 device and active in different profiles - Office and
Home). I studied the document network-profiles.html. And having
problem with dhcp profile. The problem is that eth0_dhcp is described
in ifcfg-eth0_dhcp (which is ok) but dhcpclient-client wants the file
ifcfg-eth0 which simply does not exist in my system (it uses $DEVICE
variable which points to eth0, not eth0_dhcp).

Note You need to log in before you can comment on or make changes to this bug.