Bug 974230 - dhcpd.service systemd unit does not allow additional command line arguments
dhcpd.service systemd unit does not allow additional command line arguments
Status: CLOSED DUPLICATE of bug 909733
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 14:03 EDT by Tom Horsley
Modified: 2013-06-14 03:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 03:31:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2013-06-13 14:03:55 EDT
Description of problem:

I'm running a local access point for my phone and tablet on a local subnet. I want the dhcpd I'm running to only listen on the wlan0 (or what used to be named wlan0 anyway) interface.

Apparently there is no way to specify an interface restriction in the .conf file, but I have to specify it on the command line.

Seems to be like the unit file ought to append the tradition /etc/sysconfig/dhcpd command line arguments if that file exists.

Alternately (and perhaps more sensibly) the .conf file should have some syntax to allow me to say exactly which interface to listen on.


Version-Release number of selected component (if applicable):
dhcp-4.2.5-12.fc19.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Look at unit file, see you can't add command line args conveniently
2.
3.

Actual results:
No way to add command line args

Expected results:
Way to add command line arg

Additional info:
Comment 1 Jiri Popelka 2013-06-14 03:31:48 EDT
Seems you already found bug #909733.

(In reply to Tom Horsley from comment #0)
> Apparently there is no way to specify an interface restriction in the .conf
> file, but I have to specify it on the command line.

There is actually, see bug #909733, comment #7
 
> Steps to Reproduce:
> 1. Look at unit file, see you can't add command line args conveniently

Discussed in bug #909733 several times, I haven't changed my mind since then.

*** This bug has been marked as a duplicate of bug 909733 ***

Note You need to log in before you can comment on or make changes to this bug.