Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 974264 - "System custom_info update" when used for an invalid system uuid, makes the updates to a real (incorrect) system
Summary: "System custom_info update" when used for an invalid system uuid, makes the u...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Mike McCune
QA Contact: Og Maciel
Og Maciel
URL:
Whiteboard:
Depends On:
Blocks: 896600
TreeView+ depends on / blocked
 
Reported: 2013-06-13 19:30 UTC by Apurva Bhole
Modified: 2019-09-26 15:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-18 21:20:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Apurva Bhole 2013-06-13 19:30:22 UTC
Description of problem:
When an invalid uuid is used while updating system custom info, a success message is shown instead of an error.
Also, the corresponding keyname info gets updated for a real system instead.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create an organization with name "FirstOrg"
2. Create a system "FirstSys" for FirstOrg
3. system custom_info add --org FirstOrg --name FirstSys --keyname "newKey" --value "newVal"
4. system custom_info update --org FirstOrg --uuid 98765 --keyname "newKey" --value "newVal98765"

Actual results:
1. Consol Output: 
   Successfully updated Custom Information [ newKey ] for System [ 98765 ]

2. The corresponding info gets updated for the FirstSys system. 


Expected results:
Should throw an invalid uuid error

Additional info:


Document URL: 

Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

Additional information: 


Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 RHEL Program Management 2013-06-13 19:43:04 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Og Maciel 2013-06-18 22:39:19 UTC
Another possible symptom:

katello> system packages --org SimpleOrg --uuid 6dc60321-4427-40d4-8857-0337c6b00a59 --install emacs
Found ambiguous Systems [ 6dc60321-4427-40d4-8857-0337c6b00a59 ] in Org [ SimpleOrg ]

I had talked to Apurva about this yesterday and it seems that this only manifests if there are more than 2 systems in the organization.

Comment 4 Mike McCune 2013-06-19 02:53:31 UTC
Justin, can you help determine why the API call:

/katello//api/organizations/DemoOrg/systems?uuid=f9889fa4-ca52-422b-b8c9-044d82759173 

is not filtering on that UUID?  For me it returns multiple results even when it should only find one.

Comment 5 Mike McCune 2013-06-19 02:56:59 UTC
WORKAROUND:

workaround is to use --name. there is something broken with --uuid

Comment 6 Mike McCune 2013-06-19 03:36:21 UTC
looks like the CLI needs to use a different query param that is search based:

https://github.com/Katello/katello-cli/pull/43

Comment 7 Mike McCune 2013-06-19 03:43:59 UTC
updated PR:

https://github.com/Katello/katello-cli/pull/44

43 is invalid

Comment 9 Brad Buckingham 2013-06-21 12:59:31 UTC
Mass move to ON_QA

Comment 10 Og Maciel 2013-06-22 19:32:02 UTC
[root@qeblade35 ~]# katello -u admin -p admin shell
katello> system list --org SimpleOrg
---------------------------------------------------------------------------------------------------------------------------
                                            Systems List For Org [ SimpleOrg ]

Name                          UUID                                 Environment Service Level Content View
---------------------------------------------------------------------------------------------------------------------------
og-64bit-rhel6-01.qerulez.com 6eef64ca-4db8-4f9d-8e17-4f201006ec36 Dev Env                   PublishedRHEL6Composite64
og-32bit-rhel6-01.qerulez.com 1ac3bde1-a1d6-4ebe-abd2-0c0487f116c5 Dev Env                   PublishedRHEL6Composite32
qeclient01.usersys.redhat.com 01695a9c-9cd7-4ae3-99d8-61c4d92c3259 Dev Env                   PublishedRHEL6Composite64
qeclient02.usersys.redhat.com 4e5e7113-8b3b-4baf-a777-947ab735bfbd Dev Env                   PublishedRHEL6Composite64
qeclient03.usersys.redhat.com 25afd454-c4c5-46a5-814b-248c8cd7d765 Dev Env                   PublishedRHEL6Composite64
qeclient04.usersys.redhat.com 504aada1-4369-4ce2-80a7-fe1285801f09 Dev Env                   PublishedRHEL6Composite64
qeclient05.usersys.redhat.com 3cb12af7-2945-4c55-bb9a-550242a1695a Dev Env                   PublishedRHEL6Composite64
qeclient06.usersys.redhat.com 0733a405-ba11-4915-ada1-de09096c45d7 Dev Env                   PublishedRHEL6Composite64
qeclient07.usersys.redhat.com f68681f7-6fd4-4896-b3ba-1325950bb4cd Dev Env                   PublishedRHEL6Composite64
qeclient08.usersys.redhat.com ba4594c8-c98c-4643-bc6d-276f697daadd Dev Env                   PublishedRHEL6Composite64
qeclient09.usersys.redhat.com 9bdecbef-d122-4dff-9d18-67913d1b8793 Dev Env                   PublishedRHEL6Composite64
qeclient10.usersys.redhat.com 2a4b950b-002d-472e-baf8-72bc695f6142 Dev Env                   PublishedRHEL6Composite64
qeclient11.usersys.redhat.com 0599d27d-8585-4e8a-a640-f11cd77cb8bd Dev Env                   PublishedRHEL6Composite64
qeclient12.usersys.redhat.com d53332d5-2a1e-4a85-8ab7-0ed5bee59412 Dev Env                   PublishedRHEL6Composite64
qeclient13.usersys.redhat.com e1603ad6-714b-4f29-8208-72e3239ff0de Dev Env                   PublishedRHEL6Composite64
qeclient14.usersys.redhat.com f0919524-63b9-4d65-b37e-8a2db4d5660f Dev Env                   PublishedRHEL6Composite64
qeclient15.usersys.redhat.com 653427db-fe61-4ccc-b16d-6324cae25eb8 Dev Env                   PublishedRHEL6Composite64
qeclient16.usersys.redhat.com 69d54993-1aa6-4059-8f19-9a9fa71b783a Dev Env                   PublishedRHEL6Composite64
qeclient17.usersys.redhat.com 55e10e36-91d8-4037-b178-5f18eaca0af6 Dev Env                   PublishedRHEL6Composite64
qeclient18.usersys.redhat.com c5ec654a-1caa-443e-aa76-fd1fdc01d3f0 Dev Env                   PublishedRHEL6Composite64
katello> system info --org SimpleOrg --name qeclient18.usersys.redhat.com
---------------------------------------------------------------------------------------------------------------------------
                                         System Information For Org [ SimpleOrg ]
---------------------------------------------------------------------------------------------------------------------------

Name            : qeclient18.usersys.redhat.com
IPv4 Address    : 127.0.0.1
UUID            : c5ec654a-1caa-443e-aa76-fd1fdc01d3f0
Environment     : Dev Env
Location        : None
Registered      : 2013/06/22 19:19:03
Last Updated    : 2013/06/22 19:19:03
Description:
    Initial Registration Params
Activation Keys:
    [ ActivationKey2 ]
Service Level   :
Custom Info:
    [  ]
Content View    : [ PublishedRHEL6Composite64 ]

katello> system custom_info add --org SimpleOrg --name qeclient18.usersys.redhat.com --keyname Color --value Blue
Successfully added Custom Information [ Color : Blue ] to System [ qeclient18.usersys.redhat.com ]
katello> system info --org SimpleOrg --name qeclient18.usersys.redhat.com
---------------------------------------------------------------------------------------------------------------------------
                                         System Information For Org [ SimpleOrg ]
---------------------------------------------------------------------------------------------------------------------------

Name            : qeclient18.usersys.redhat.com
IPv4 Address    : 127.0.0.1
UUID            : c5ec654a-1caa-443e-aa76-fd1fdc01d3f0
Environment     : Dev Env
Location        : None
Registered      : 2013/06/22 19:19:03
Last Updated    : 2013/06/22 19:19:03
Description:
    Initial Registration Params
Activation Keys:
    [ ActivationKey2 ]
Service Level   :
Custom Info:
    [ Color: Blue ]
Content View    : [ PublishedRHEL6Composite64 ]

katello> system custom_info update --org SimpleOrg --uuid c5ec654a-1caa-443e-aa76-fd1fdc01d3f0 --keyname Color --value Yellow
Successfully updated Custom Information [ Color ] for System [ c5ec654a-1caa-443e-aa76-fd1fdc01d3f0 ]
katello> system info --org SimpleOrg --name qeclient18.usersys.redhat.com---------------------------------------------------------------------------------------------------------------------------
                                         System Information For Org [ SimpleOrg ]
---------------------------------------------------------------------------------------------------------------------------

Name            : qeclient18.usersys.redhat.com
IPv4 Address    : 127.0.0.1
UUID            : c5ec654a-1caa-443e-aa76-fd1fdc01d3f0
Environment     : Dev Env
Location        : None
Registered      : 2013/06/22 19:19:03
Last Updated    : 2013/06/22 19:19:03
Description:
    Initial Registration Params
Activation Keys:
    [ ActivationKey2 ]
Service Level   :
Custom Info:
    [ Color: Yellow ]
Content View    : [ PublishedRHEL6Composite64 ]

katello> system custom_info update --org SimpleOrg --name qeclient18.usersys.redhat.com --keyname Color --value Green
Successfully updated Custom Information [ Color ] for System [ qeclient18.usersys.redhat.com ]
katello> system info --org SimpleOrg --name qeclient18.usersys.redhat.com
---------------------------------------------------------------------------------------------------------------------------
                                         System Information For Org [ SimpleOrg ]
---------------------------------------------------------------------------------------------------------------------------

Name            : qeclient18.usersys.redhat.com
IPv4 Address    : 127.0.0.1
UUID            : c5ec654a-1caa-443e-aa76-fd1fdc01d3f0
Environment     : Dev Env
Location        : None
Registered      : 2013/06/22 19:19:03
Last Updated    : 2013/06/22 19:19:03
Description:
    Initial Registration Params
Activation Keys:
    [ ActivationKey2 ]
Service Level   :
Custom Info:
    [ Color: Green ]
Content View    : [ PublishedRHEL6Composite64 ]

katello> system info --org SimpleOrg --uuid c5ec654a-1caa-443e-aa76-fd1fdc01d3f0
---------------------------------------------------------------------------------------------------------------------------
                                System Information [ c5ec654a-1caa-443e-aa76-fd1fdc01d3f0 ]
---------------------------------------------------------------------------------------------------------------------------

Name            : qeclient18.usersys.redhat.com
IPv4 Address    : 127.0.0.1
UUID            : c5ec654a-1caa-443e-aa76-fd1fdc01d3f0
Environment     : Dev Env
Location        : None
Registered      : 2013/06/22 19:19:03
Last Updated    : 2013/06/22 19:19:03
Description:
    Initial Registration Params
Activation Keys:
    [ ActivationKey2 ]
Service Level   :
Custom Info:
    [ Color: Green ]
Content View    : [ PublishedRHEL6Composite64 ]

Comment 11 Og Maciel 2013-06-22 19:33:20 UTC
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10014-1.noarch
* foreman-compute-1.1.10014-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10014-1.noarch
* foreman-postgresql-1.1.10014-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-17.el6sat.noarch
* katello-all-1.4.2-17.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-8.el6sat.noarch
* katello-cli-common-1.4.2-8.el6sat.noarch
* katello-common-1.4.2-17.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-17.el6sat.noarch
* katello-glue-candlepin-1.4.2-17.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-17.el6sat.noarch
* katello-glue-pulp-1.4.2-17.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-1.el6sat.noarch
* pulp-selinux-2.1.2-1.el6sat.noarch
* pulp-server-2.1.2-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* ruby193-rubygem-runcible-0.4.10-1.el6sat.noarch
* signo-0.0.19-1.el6sat.noarch
* signo-katello-0.0.19-1.el6sat.noarch

Comment 12 Mike McCune 2013-07-18 21:20:15 UTC
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.


Note You need to log in before you can comment on or make changes to this bug.