Bug 974287 - memory leak in virt-manager
memory leak in virt-manager
Status: CLOSED DUPLICATE of bug 972371
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 16:39 EDT by Zbigniew Jędrzejewski-Szmek
Modified: 2013-06-14 09:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 09:11:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zbigniew Jędrzejewski-Szmek 2013-06-13 16:39:47 EDT
Description of problem:
I left virt-manager monitoring one running machine for about two days and it run up to 1772MB virtual, 504MB RSS.

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-0.5.gitde1695b2.fc19.noarch
python-2.7.5-1.fc19.x86_64
pygtk2-2.24.0-7.fc19.x86_64

How reproducible:
Haven't noticed this before, but I usually don't leave virt-manager running for long.

Additional info:
(gdb) heap sizes
Chunk size  Num chunks  Allocated size
----------  ----------  --------------
       512      311731     159,606,272
        32     4536973     145,183,136
        48     1016696      48,801,408
       112      188793      21,144,816
   262,160          42      11,010,720
        96       94381       9,060,576
        64       95361       6,103,104
 4,194,320           1       4,194,320
    12,304         267       3,285,168
 3,149,824           1       3,149,824
       288        6379       1,837,152
       544        2906       1,580,864
     1,024        1312       1,343,488
   266,240           5       1,331,200
     3,088         326       1,006,688
...

I don't know what those 32 and 48 byte chunks are, but there's lots of them. Unfortunately gdb-heap isn't fully working.

I'll keep this virt-manager instance around for now, so ping me if I can provide additional info.
Comment 1 Cole Robinson 2013-06-14 09:11:30 EDT

*** This bug has been marked as a duplicate of bug 972371 ***
Comment 2 Cole Robinson 2013-06-14 09:12:18 EDT
Thanks for the offer, it's easily reproducible for me so feel free to kill your virt-manager instance before it engulfs your machine :)

Note You need to log in before you can comment on or make changes to this bug.