Bug 97430 - Apache or PHP POST bug
Apache or PHP POST bug
Status: CLOSED DUPLICATE of bug 82967
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Joe Orton
David Lawrence
http://ruslug.rutgers.edu/~mcgrof/tes...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-15 11:18 EDT by Luis R. Rodriguez
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis R. Rodriguez 2003-06-15 11:18:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020623
Debian/1.2.5-0.woody.1

Description of problem:
When a variables is passed on PHP on Apache 2.0.40, the variable's value is not
set correctly. It may be a php bug, but I have been told that it just might be
an apache bug. To verify a script in perl can be written to use POST method
similar to the one on the URL posted.



Version-Release number of selected component (if applicable):
httpd-2.0.40-21.3

How reproducible:
Always

Steps to Reproduce:
1a. Install RH 8, 
It's a bug here too, if I remember correctly

1b. Install RH 8
2b. Use apt for rpms to upgrade to RH 9
Bug should occur still

1c. Install RH 9
Bug should occur

1d. Instal RH 8
2d. upgrade to RH  9
Bug should occur

1e. Install RH 8
2e. Upgrade to RH 9 through apt for rpms
Bug should still occur

1f. Install RH 8
2f. Upgrade to RH9 through apt for rpms
3f. Use up2date to upgrade system
Bug should still occur

Actual Results:  I get as output for the license variable:
"I acceptlicense=I accept"


Expected Results:  
Correct output should be
"I accept"

Additional info:

apache stable 2.0.46 is out. RH does not yet have that rpm available. I've asked
on irc.redhat.com about the bug on #apache and #php and no one was sure of the
bug. PHP people blamed apache. 

I'm noting it as with high priority since it ruins many POST method web apps and
there is no easy way out of it.
Comment 1 Luis R. Rodriguez 2003-06-16 11:29:38 EDT
The okuili.com server on which the test page was on is now down and that is
because I am installing Debian on it now. But, the test page/tarball is still
available at:
http://ruslug.rutgers.edu/~mcgrof/test/reg.php
Comment 2 Joe Orton 2003-06-21 05:38:23 EDT
Have you added "AddType application/x-httpd-php .php" to your httpd.conf?  You
shouldn't add that for the PHP package in Red Hat Linux 8.0 and 9. This is
probably a duplicate of bug 82967.
Comment 3 Luis R. Rodriguez 2003-06-26 10:40:15 EDT
If I remember correctly, I did have that option set. If the other bug had that
as the main problem, then yes this is probably, 80% sure, a duplicate bug. 

Unfortunately, this was not obvious to the end user. I can't imagine the amount
of RH machines out there with the same setup.

Comment 4 Joe Orton 2003-06-26 10:57:00 EDT
Yes, a forthcoming erratum will allow PHP to work correctly even if that AddType
directive is configured.  I'll close this as a duplicate; thanks for submitting
 the report.

*** This bug has been marked as a duplicate of 82967 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:56:44 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.