Bug 974310 - Software Selection spoke doesn't re-calculate dependencies when changing installation sources if the original source results in an error
Software Selection spoke doesn't re-calculate dependencies when changing inst...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All All
unspecified Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 19:04 EDT by Adam Williamson
Modified: 2014-01-31 20:00 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-21.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-31 20:00:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-06-13 19:04:35 EDT
To see what I mean, compare the two cases - 'normal' and 'error'.

In the 'normal' case, you boot the installer, and whatever your default Installation Source is, the Software Selection spoke is happy - it runs through its 'set up repo, check package set dependencies' cycle and sits there showing 'GNOME Desktop'. Now if you change to a different 'Installation Source', the 'Software Selection' spoke will switch to an orange-flag condition asking you to go in and out of it again to make sure the package set you want is still OK. Fine.

However, now consider the 'error' case. In this case, the default Installation Source results in an error in Software Selection. Right now you can reproduce this by booting Final TC3 netinst.iso because of the sssd dependency error, but that's getting fixed, so I don't know how long this will last. If you now change to a different Installation Source - I changed to an NFSv4 repo containing the Final TC3 DVD ISO - the Software Selection spoke doesn't change at all: it still shows the same error, the "Error checking software selection" error. Just going into Software Selection and out again isn't sufficient to shift it. You have to do the dodge where you go in, change to something other than GNOME, go out, go back in, and change back to GNOME: then it's happy.

The 'when the user changes Installation Source, make the user go through the Software Selection spoke, and have the spoke re-check the dependencies' thing should work even when the previous 'Installation Source' resulted in an error in the Software Selection spoke, not only when it resulted in success.
Comment 1 Adam Williamson 2013-06-13 19:15:16 EDT
bcl asked what happens if I go into the spoke when it shows the error condition and click on the error. Good question.

If I do that, a dialog pops up showing the actual errors - which are the errors related to the initial broken installation source (in this case, the sssd errors, which do not exist on the DVD ISO). The dialog offers Cancel, Quit and Modify Software Source as options. Hitting Cancel goes back to showing the Software Selection spoke, with the orange error bar still intact: hitting Done at this point goes back to Overview with the Software Selection spoke still in the error condition - i.e. it doesn't help at all, whereas bcl thought it might.
Comment 2 Brian Lane 2014-01-31 20:00:57 EST
This has been fixed and will be in F21.

Note You need to log in before you can comment on or make changes to this bug.