Bug 974334 - mtr-gtk can't be started from Gnome
mtr-gtk can't be started from Gnome
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mtr (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Sekletar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 22:20 EDT by Eric Smith
Modified: 2013-10-18 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: mtr-0.84-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 02:40:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Smith 2013-06-13 22:20:36 EDT
Description of problem:
Trying to start xmtr application ("Traceroute") from Gnome silently fails, though it logs two messages to /var/log/messages:

<timestamp> localhost /etc/gdm/Xsession[<pid>]: The password you typed is invalid.
<timestamp> localhost /etc/gdm/Xsession[<pid>]: Please try again.

I can start xmtr from a command line, and am prompted for the root password, and the app starts properly.


Version-Release number of selected component (if applicable):
mtr-gtk-0.84-1.fc19

How reproducible:
100%

Steps to Reproduce:
1. From Gnome Shell, try to start the "Traceroute" application
2. Watch in amazement as nothing whatsoever happens

Actual results:
nothing happens

Expected results:
application starts

Additional info:
Quite possibly the same root cause as bug #882555 for gsmartcontrol, as both apps have the same behavior including the log messages, and both use consolehelper with identical PAM configuration files.
Comment 1 Michal Sekletar 2013-07-04 07:45:38 EDT
I am unable to reproduce the bug. Everything works as expected on my machine. I will be releasing new version mtr-0.85, although I don't expect the new version to fix this for you, since it looks like consolehelper/pam issue.
Comment 2 Michal Sekletar 2013-09-17 07:18:04 EDT
I am able to reproduce the bug. I wasn't able to that previously. I suspect that previously I was using some older version of dependent component thus bug didn't occurred. I will try to come up with patches and move to polkit instead, we need to do that anyway.
Comment 3 Eric Smith 2013-09-17 11:45:46 EDT
Thanks for the assistance. Maybe I'm dense, but I couldn't figure out from the polkit documentation how to do this.
Comment 4 Fedora Update System 2013-10-08 10:43:33 EDT
mtr-0.84-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mtr-0.84-3.fc19
Comment 5 Fedora Update System 2013-10-08 10:49:48 EDT
mtr-0.85-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mtr-0.85-3.fc20
Comment 6 Fedora Update System 2013-10-09 10:51:38 EDT
Package mtr-0.85-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mtr-0.85-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18584/mtr-0.85-3.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-10-15 02:40:38 EDT
mtr-0.85-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-10-18 15:56:53 EDT
mtr-0.84-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.