This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 97441 - gaim-0.64 MSN crash fixes
gaim-0.64 MSN crash fixes
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gaim (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-15 18:47 EDT by Warren Togami
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 19:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2003-06-15 18:47:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030611

Description of problem:
gaim-0.64 has several flaws that can cause segfaults if using the MSN protocol.
 ChipX86 has fixed most of these crashes in CVS.

http://www.togami.com/~warren/archive/2003/gaim-0.64-msncrashes.diff
unidiff against gaim-0.64 manually applied

http://bugzilla.fedora.us/show_bug.cgi?id=297
WORKSFORME, but still undergoing testing in Fedora

Version-Release number of selected component (if applicable):
gaim-0.64-1

How reproducible:
Always

Steps to Reproduce:
1. Use MSN protocol, send or receive authorization requests for adding a MSN buddy.

Actual Results:  
Crash
Comment 1 Warren Togami 2003-06-20 02:59:30 EDT
http://sourceforge.net/mailarchive/forum.php?thread_id=2606774&forum_id=33079
Fixes non-critical but annoying "MSN: Invalid User" warning box when you add and
remove a MSN buddy.  This patch is untested, but the previous patch works very well.
Comment 2 Warren Togami 2003-06-20 03:01:24 EDT
Procedure for reproducing Comment #1.
1. Apply first patch.
2. Use MSN protocol.
3. Add a few MSN buddies.
4. Remove those MSN buddies.
5. Close gaim, open gaim, login.
6. "MSN: Invalid User" warning boxes due to erroneous numbers in ~/.gaim/blist.xml
Comment 3 Warren Togami 2003-06-20 03:51:25 EDT
I retract Comment #1, the patch introduces a new crash that cannot be fixed
without massive changes in 0.65 CVS.  The original patch is good enough for now.
Comment 4 Bill Nottingham 2003-07-24 19:25:21 EDT
0.66 should be in rawhide shortly.

Note You need to log in before you can comment on or make changes to this bug.