Bug 974425 - Inconsistent title of pager icon in "Task List (Advanced View)"
Inconsistent title of pager icon in "Task List (Advanced View)"
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low
: DR6
: 6.0.0
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 03:45 EDT by Jan Hrcek
Modified: 2014-08-06 16:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:06:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Paging icon (36.22 KB, image/png)
2013-06-14 03:45 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-06-14 03:45:57 EDT
Created attachment 761128 [details]
Paging icon

Description of problem:
See printscreen. While the first 3 icons are named:
1) First page
2) Previous page
3) Next page

the 4th is named 
4) Fast forward

 -> Should be renamed to "Last page" to be consistent with the first three

Version-Release number of selected component (if applicable):
business-central DR5
Comment 1 Mauricio Salatino 2013-06-24 10:35:55 EDT
fixed in master and beta4
Comment 3 Jan Hrcek 2013-07-02 07:38:24 EDT
I checked with Beta 4 and the problem is still present -> The button still has title "Fast forward"

i.e. the anchor element in the web page is rendered as 
<a id="gwt-uid-173" class="btn btn-link disabled GJ--WOXHO" href="javascript:;" data-original-title="Fast forward">

There is also probably related bug about this button, that unlike the previous 3 paging buttons it doesn't work - it is allways disabled.
For example add 60 tasks (= 2 pages of tasks) and then try to use paging buttons like next - previous - next - first. The buttons are enabled/disabled based on your currently displayed list page, but "Fast forward" is allways disabled and doesn't work.
Comment 4 Mauricio Salatino 2013-07-02 15:32:36 EDT
I will check this, but this is the standard pager that comes with the GWT Bootstrap libs. It's not inside the jbpm console ng. I guess that all the pagers in the apps will have that Title.
Comment 5 Jan Hrcek 2013-07-03 01:33:40 EDT
Yes, you're right. I checked the sources and the label "Fast forward" is hardcoded in https://github.com/gwtbootstrap/gwt-bootstrap/blob/master/src/main/java/com/github/gwtbootstrap/client/ui/SimplePager.java . Also the faulty logic for disabling/enabling the paging buttons reside in that class.
Comment 6 Jan Hrcek 2013-07-03 01:49:49 EDT
EDIT: upon closer inspection I just found that it's actually not a bug, it's a feature :D

There are 3 ways this SimplePager gives to move forward in a paged list
1) with "Next page" (1 page forward)
2) with "Fast forward" button - moving forward by more pages (enabled when 100+ items are in the list) - This button is enabled by default when using no-param constructor of SimplePager.
3) with "Last Page" button. This is disabled by default.

So in our case (List of tasks - can get quite long when displaying All tasks in a Grid view) I would recommend enabling the "Last Page" button by using different constructor in TasksListViewImpl class.
Comment 7 Mauricio Salatino 2013-07-03 03:46:46 EDT
Sounds good.. i will check it out and change the bz status
Comment 8 Mauricio Salatino 2013-07-03 08:03:34 EDT
Fixed in master
Comment 10 Jan Hrcek 2013-07-11 01:35:16 EDT
The commit that fixes this problem is (note, that BZ number in the commit message is incorrect)

https://github.com/droolsjbpm/jbpm-console-ng/commit/a016848d9b4e835fbf318066f6450a23686e7c28
Comment 11 Jan Hrcek 2013-07-11 08:46:15 EDT
Verified with DR6 deployed on EAP 6.1

Note You need to log in before you can comment on or make changes to this bug.