Bug 974429 - Very chatty in journal
Very chatty in journal
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedmsg-notify (Show other bugs)
19
All All
unspecified Severity high
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 03:49 EDT by Adam Williamson
Modified: 2016-09-19 22:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: fedmsg-notify-0.5.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-29 14:07:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-06-14 03:49:49 EDT
The fedmsg extension (at least, I think it's the Shell extension) seems extremely chatty in the journald logs. My journalctl output is stuffed with this:

Jun 14 00:33:01 adam.localdomain /etc/gdm/Xsession[1637]: [moksha.hub] DEBUG 2013-06-14 00:33:01,309 Message to org.fedoraproject.prod.buildsys.repo.init didn't match filters
Jun 14 00:34:14 adam.localdomain /etc/gdm/Xsession[1637]: [moksha.hub] DEBUG 2013-06-14 00:34:14,349 Message to org.fedoraproject.prod.buildsys.build.state.change didn't match filters

i.e. every time a message is emitted by fedmsg that doesn't match the filters for the extension to notify me of it, the fact is logged to the journal. That seems...unnecessary.
Comment 1 Patrick Uiterwijk 2013-06-17 05:07:07 EDT
The extension only listens to the dbus, and does not handle the moksha hub connection, this is fedmsg itself.

Re-assigning.
Comment 2 Ralph Bean 2013-06-17 09:40:22 EDT
The log message originates from here, making it a part of fedmsg-notify.

https://github.com/fedora-infra/fedmsg-notify/blob/develop/fedmsg_notify/daemon.py#L188

Changing component.
Comment 4 Fedora Update System 2013-06-18 15:32:12 EDT
fedmsg-notify-0.5.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedmsg-notify-0.5.1-1.fc19
Comment 5 Ralph Bean 2013-06-18 16:53:02 EDT
Luke, looks like you accidentally pasted the wrong commit.  It is fixed upstream, but in this one:  https://github.com/fedora-infra/fedmsg-notify/commit/095adbdaff0d899150cf9e3d4800331c9bfbe4b1

Thanks for fixing!
Comment 6 Fedora Update System 2013-06-19 09:09:19 EDT
Package fedmsg-notify-0.5.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedmsg-notify-0.5.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11270/fedmsg-notify-0.5.1-1.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-06-29 14:07:57 EDT
fedmsg-notify-0.5.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.