Bug 974456 - Message after updating distributor name with a blank field is invalid
Message after updating distributor name with a blank field is invalid
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.1
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
sthirugn@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 04:35 EDT by Tazim Kolhar
Modified: 2014-06-19 15:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-30 13:47:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-06-14 04:35:56 EDT
Description of problem:
Message after updating distributor name with a blank field is invalid

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
signo-katello-0.0.9-1.el6.noarch
katello-headpin-1.4.2-1.git.638.2148be1.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.90.6c7a175.el6.noarch
katello-cli-common-1.4.2-1.git.90.6c7a175.el6.noarch
katello-glue-candlepin-1.4.2-1.git.638.2148be1.el6.noarch
katello-configure-1.4.3-1.git.62.f050662.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.2-1.git.638.2148be1.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-common-1.4.2-1.git.638.2148be1.el6.noarch
katello-headpin-all-1.4.2-1.git.638.2148be1.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --user-pass=***

Steps to Reproduce:
1.# headpin -u admin -p *** distributor update --org test --name test_new_dis --new_name ""
Successfully updated distributor [ test_new_dis ]

2.]# headpin -u admin -p *** distributor info --name "" --org test
Could not find Distributor [  ] in Org [ test ]

3.# headpin -u admin -p *** distributor info --name test_new_dis --org test
--------------------------------------------------------------------------------
                    Distributor Information For Org [ test ]
--------------------------------------------------------------------------------

Name         : test_new_dis
UUID         : 7683fc70-2f35-4206-beaa-8b2c7808b7d9
Environment  : Library
Created      : 2013/06/14 08:07:03
Last Updated : 2013/06/14 08:26:53
Description:
    Initial Creation Params
Custom Info:
    [  ]

# echo $?
0



Actual results:

The message is invalid and the return exit code is 0

Expected results:
The message should be something like 
"Distributor name cannot be blank"
The return exitcode should not be 0 

Additional info:
Comment 1 RHEL Product and Program Management 2013-06-14 04:56:13 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 sthirugn@redhat.com 2014-04-30 13:47:09 EDT
Custom Distributor not relevant to Sat 6 now.

Note You need to log in before you can comment on or make changes to this bug.