Bug 974463 - Doubling of 'Remove' and 'Attach' buttons in Systems -> Subscriptions
Doubling of 'Remove' and 'Attach' buttons in Systems -> Subscriptions
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: Splice Developers
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-06-14 04:44 EDT by Vitaly Kuznetsov
Modified: 2013-10-01 06:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:57:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Subscriptions with two Remove buttons (114.77 KB, image/png)
2013-06-14 04:44 EDT, Vitaly Kuznetsov
no flags Details
Subscriptions with two Attach buttons (114.93 KB, image/png)
2013-06-14 04:45 EDT, Vitaly Kuznetsov
no flags Details

  None (edit)
Description Vitaly Kuznetsov 2013-06-14 04:44:48 EDT
Created attachment 761154 [details]
Subscriptions with two Remove buttons

Description of problem:
There are two 'Remove' (when subscription is attached) and two 'Attach' (when subscription is detached) buttons in Systems -> Subscriptions. Screenshots attached.

Version-Release number of selected component (if applicable):
katello-headpin-1.4.2-13.el6sam_splice_2.noarch

How reproducible:
always

Steps to Reproduce:
1. Have one system in 'Current' status
2. Go to 'Subscriptions', there are two Remove buttons there
3. Remove a subscription, update. There are two Attach buttons there now

Actual results:
Two 'Remove' and two 'Attach' buttons

Expected results:
One 'Remove' and one 'Attach' button

Additional info:
Google Chrome browser.
Comment 1 Vitaly Kuznetsov 2013-06-14 04:45:25 EDT
Created attachment 761155 [details]
Subscriptions with two Attach buttons
Comment 2 Bryan Kearney 2013-07-19 16:43:06 EDT
this is in the splice bits.
Comment 3 Vitaly Kuznetsov 2013-07-22 07:55:03 EDT
I'm not sure this bug has something to do with splice bits (as it was feasible in standard 'Systems' interface, not in reports).

However I've checked katello-nightly and there is no such bug there. We can just make sure these bits will land in SAM-1.3.
Comment 6 Vitaly Kuznetsov 2013-08-21 09:30:15 EDT
Verified in:
katello-selinux-1.4.4-2.el6sat.noarch
katello-headpin-all-1.4.3-8.el6sam_splice.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-1.4.3-7.el6sat.noarch
signo-katello-0.0.20-1.el6sat.noarch
katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
splice-0.142-1.el6sam.noarch
katello-cli-common-1.4.3-7.el6sat.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-common-1.4.3-8.el6sam_splice.noarch
katello-headpin-1.4.3-8.el6sam_splice.noarch
spacewalk-splice-tool-0.39-1.el6sam.noarch
splice-common-config-0.142-1.el6sam.noarch
splice-common-0.142-1.el6sam.noarch
ruby193-rubygem-splice_reports-0.0.5-40.el6sam.noarch
katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
splice-selinux-0.142-1.el6sam.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
Comment 8 errata-xmlrpc 2013-10-01 06:57:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.