Bug 974467 - FSError: umount failed
FSError: umount failed
Status: CLOSED DUPLICATE of bug 968833
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:6f06c46cf52bcb2d1075b7754ac...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 04:52 EDT by Felix Miata
Modified: 2014-12-08 16:56 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-08 16:56:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (918.55 KB, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: anaconda.log (5.02 KB, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: backtrace (1.14 KB, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: environ (634 bytes, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: ifcfg.log (483 bytes, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: lsblk_output (3.50 KB, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: nmcli_dev_list (1.27 KB, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: packaging.log (410 bytes, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: program.log (74.06 KB, text/plain)
2013-06-14 04:52 EDT, Felix Miata
no flags Details
File: storage.log (637.79 KB, text/plain)
2013-06-14 04:53 EDT, Felix Miata
no flags Details
File: syslog (61.59 KB, text/plain)
2013-06-14 04:53 EDT, Felix Miata
no flags Details
program.log from RC2 (68.51 KB, text/plain)
2013-06-27 14:06 EDT, Felix Miata
no flags Details
RC2 output from lsof (271.58 KB, text/plain)
2013-06-27 14:07 EDT, Felix Miata
no flags Details

  None (edit)
Description Felix Miata 2013-06-14 04:52:04 EDT
Description of problem:
HTTP installation initialized by Grub Legacy. No idea why this happened. I've initialized probably at least 40 installation attempts in past 30 hours.I'm guessing these early crashes are happening only slightly less than half the time.
The following was filed automatically by anaconda:
anaconda 19.30.3-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 626, in unmount
    raise FSError("umount failed")
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 792, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 745, in _preTeardown
    self.format.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 757, in teardown
    if not self._preTeardown(recursive=recursive):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2803, in findExistingInstallations
    device.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 420, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 140, in storageInitialize
    storage.reset()
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
FSError: umount failed

Version-Release number of selected component:
anaconda-19.30.3-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   stage2=hd:/dev/sda13:/squashfs.img repo=http://alt.fedoraproject.org/pub/alt/stage/19-TC3/Fedora/i386/os selinux=0 ip=192.168.0.62::192.168.0.50:255.255.255.0:kt880::none nameserver=192.168.0.50 video=1152x864 vga=794 noapic resolution='1280x960' splash=verbose rd.luks=0 rd.md=0 rd.dm=0 nousb nofirewire noipv6
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.4-301.fc19.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 140, in storageInitialize
    storage.reset()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 420, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2803, in findExistingInstallations
    device.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 757, in teardown
    if not self._preTeardown(recursive=recursive):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 745, in _preTeardown
    self.format.teardown()
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 792, in teardown
    return self.unmount(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 626, in unmount
    raise FSError("umount failed")
FSError: umount failed
Comment 1 Felix Miata 2013-06-14 04:52:17 EDT
Created attachment 761157 [details]
File: anaconda-tb
Comment 2 Felix Miata 2013-06-14 04:52:22 EDT
Created attachment 761158 [details]
File: anaconda.log
Comment 3 Felix Miata 2013-06-14 04:52:26 EDT
Created attachment 761159 [details]
File: backtrace
Comment 4 Felix Miata 2013-06-14 04:52:30 EDT
Created attachment 761160 [details]
File: environ
Comment 5 Felix Miata 2013-06-14 04:52:33 EDT
Created attachment 761161 [details]
File: ifcfg.log
Comment 6 Felix Miata 2013-06-14 04:52:37 EDT
Created attachment 761162 [details]
File: lsblk_output
Comment 7 Felix Miata 2013-06-14 04:52:44 EDT
Created attachment 761163 [details]
File: nmcli_dev_list
Comment 8 Felix Miata 2013-06-14 04:52:49 EDT
Created attachment 761164 [details]
File: packaging.log
Comment 9 Felix Miata 2013-06-14 04:52:53 EDT
Created attachment 761165 [details]
File: program.log
Comment 10 Felix Miata 2013-06-14 04:53:02 EDT
Created attachment 761166 [details]
File: storage.log
Comment 11 Felix Miata 2013-06-14 04:53:09 EDT
Created attachment 761167 [details]
File: syslog
Comment 12 Brian Lane 2013-06-14 20:25:26 EDT
I've added some debugging (and a udev settle) in 19.30.7, if you can get it to fail with TC4 (when it is ready) and grab the program.log with the output from lsof that would be great.
Comment 13 Felix Miata 2013-06-15 18:18:56 EDT
I tried using http://alt.fedoraproject.org/pub/alt/anaconda/anaconda-19.30.7-boot.iso but this bug is from a 32 bit system, and that iso appears to be only for 64 bit.
Comment 14 Felix Miata 2013-06-27 14:06:48 EDT
Created attachment 766273 [details]
program.log from RC2
Comment 15 Felix Miata 2013-06-27 14:07:13 EDT
Created attachment 766274 [details]
RC2 output from lsof

No improvement as of F19RC2.
Comment 16 David Shea 2014-12-08 16:56:21 EST

*** This bug has been marked as a duplicate of bug 968833 ***

Note You need to log in before you can comment on or make changes to this bug.