Bug 974471 - pam_cgroup is slow when cgrules.conf and /etc/passwd are large
pam_cgroup is slow when cgrules.conf and /etc/passwd are large
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcgroup (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Peter Schiffer
Red Hat Kernel QE team
: ZStream
Depends On: 972893
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 04:54 EDT by Jan Kurik
Modified: 2013-06-25 10:07 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the pam_cgoup PAM module did not use cache. Consequently, when a system had several thousand users and the cgrules.conf file contained several thousand lines of configuration settings, the login time could take several seconds. This was because the libcgroup code read /etc/passwd once for every line in cgrules.conf, unless the CGFLAG_USECACHE flag was used. With this update, the libcgroup code no longer reads the /etc/passwd file once for every line in cgrules.conf, and the login time is no longer affected in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 10:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2013-06-14 04:54:29 EDT
This bug has been copied from bug #972893 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 5 Mike Gahagan 2013-06-19 15:08:05 EDT
bug reproduced with libcgroup-0.37-7.1.el6_4 and fix verified with libcgroup-0.37-7.2.el6_4 per reproducer in bz 972893.
Comment 7 errata-xmlrpc 2013-06-25 10:07:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0975.html

Note You need to log in before you can comment on or make changes to this bug.