Bug 974482 - RFE: add freeipa CA to the system-wide trust store
RFE: add freeipa CA to the system-wide trust store
Status: CLOSED DUPLICATE of bug 928478
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:13 EDT by David Jaša
Modified: 2013-06-14 07:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 07:03:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2013-06-14 05:13:24 EDT
Description of problem:
Fedora from F19 on has a shared trust store where CA's can be added and removed on the fly. [1] FreeIPA should add it's CA there as well if it creates one. CLI instructions to achieve that are described at [2].

[1] https://fedoraproject.org/wiki/Features/SharedSystemCertificates
[2] https://fedoraproject.org/wiki/Features/SharedSystemCertificates:Testing#How_to_add_a_systemwide_CA

IMO it's in FreeIPA scope to manage CAs in the clients, too, but that's matter for another RFE (that would span SSSD, too).

Version-Release number of selected component (if applicable):
freeipa 3.2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Martin Kosek 2013-06-14 07:03:21 EDT
Good point. Current plan is to do that in Fedora 20 as I think it won't be just a matter of just running these 2 commands. IPA also configures other services and their certificates (ldap, http), we also have several certificate operation modes (dogtag vs. ca-less install) which needs to be well thought through.

Anyway, marking this Bug as duplicate to Bug 928478 which was already filed for Fedora.

*** This bug has been marked as a duplicate of bug 928478 ***

Note You need to log in before you can comment on or make changes to this bug.