Bug 974484 - [abrt] gnome-abrt-0.2.12-3.fc19: dbus_problems.py:79:_connect_to_problems_bus:UnavailableSource: Не удалось подключиться к системной шине DBus «org.freedesktop.problems» (путь «/org/freedesktop/problems»): ...
[abrt] gnome-abrt-0.2.12-3.fc19: dbus_problems.py:79:_connect_to_problems_bus...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-abrt (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
abrt_hash:020424cb8dceef0951d636a4215...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:14 EDT by Mikhail
Modified: 2016-11-30 19:44 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 04:22:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.10 KB, text/plain)
2013-06-14 05:14 EDT, Mikhail
no flags Details
File: core_backtrace (856 bytes, text/plain)
2013-06-14 05:14 EDT, Mikhail
no flags Details
File: environ (1.36 KB, text/plain)
2013-06-14 05:14 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2013-06-14 05:14:15 EDT
Version-Release number of selected component:
gnome-abrt-0.2.12-3.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        python /usr/bin/gnome-abrt
executable:     /usr/bin/gnome-abrt
kernel:         3.9.5-301.fc19.i686
runlevel:       N 5
uid:            1000

Truncated backtrace:
dbus_problems.py:79:_connect_to_problems_bus:UnavailableSource: Не удалось подключиться к системной шине DBus «org.freedesktop.problems» (путь «/org/freedesktop/problems»): Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gnome_abrt/views.py", line 426, in on_tvs_problems_changed
    self._set_problem(selection[0])
  File "/usr/lib/python2.7/site-packages/gnome_abrt/views.py", line 368, in _set_problem
    sensitive_btn and not problem['not-reportable'] )
  File "/usr/lib/python2.7/site-packages/gnome_abrt/problems.py", line 163, in __getitem__
    loaded = self.__loaditems__(item)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/problems.py", line 138, in __loaditems__
    items = self.source.get_items(self.problem_id, *args)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/dbus_problems.py", line 151, in get_items
    problem_id, args)
  File "/usr/lib/python2.7/site-packages/gnome_abrt/dbus_problems.py", line 102, in _send_dbus_message
    self._connect_to_problems_bus()
  File "/usr/lib/python2.7/site-packages/gnome_abrt/dbus_problems.py", line 79, in _connect_to_problems_bus
    .format(BUS_NAME, BUS_PATH, ex.message))
UnavailableSource: Не удалось подключиться к системной шине DBus «org.freedesktop.problems» (путь «/org/freedesktop/problems»): Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Local variables in innermost frame:
self: <gnome_abrt.dbus_problems.DBusProblemSource object at 0x8853dcc>
ex: DBusException('Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.',)
Comment 1 Mikhail 2013-06-14 05:14:19 EDT
Created attachment 761180 [details]
File: backtrace
Comment 2 Mikhail 2013-06-14 05:14:23 EDT
Created attachment 761181 [details]
File: core_backtrace
Comment 3 Mikhail 2013-06-14 05:14:26 EDT
Created attachment 761182 [details]
File: environ
Comment 4 Jakub Filak 2013-08-15 04:22:52 EDT
I believe that this bug is fixed in gnome-abrt-0.3.0 because problem source management has been completely rewritten with emphasis on proper handling of unavailable sources.

Note You need to log in before you can comment on or make changes to this bug.