Bug 974486 - CLI - system tasks returns empty list and error
CLI - system tasks returns empty list and error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Eric Helms
Og Maciel
: Triaged
Depends On: 1016624 1016874
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:14 EDT by Ales Dujicek
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:10:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-06-14 05:14:57 EDT
Description of problem:

- when you register system using subscription-manager, then
"system tasks" command returns empty list

# subscription-manager register --name sys --org "orgcon-1371196880" --force

katello> system tasks --org orgcon-1371196880 --name sys
--------------------------------------------------------------------------------
                                  Remote tasks

Task ID System Action Status 
--------------------------------------------------------------------------------

in UI there is at least "admin created new consumer system" event listed



- when you register system using "system register" command, then
"system tasks" returns error

katello> system register --org orgcon-1371196880 --name tmpsys1
Successfully registered system [ tmpsys1 ]

katello> system tasks --org orgcon-1371196880 --name tmpsys1
{"http_request_method": "GET", "exception": null, "error_message": "Task Not Found: {'resource_id': u'8aa2b6a53f41a2ba013f41dc03af0024'}", "_href": "/pulp/api/v2/tasks/8aa2b6a53f41a2ba013f41dc03af0024/", "http_status": 404, "traceback": null, "resources": {"resource_id": "8aa2b6a53f41a2ba013f41dc03af0024"}}


Version-Release number of selected component (if applicable):
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.62.f050662.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.2-1.git.654.58f211f.el6.noarch
katello-all-1.4.2-1.git.654.58f211f.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.90.6c7a175.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.90.6c7a175.el6.noarch
katello-glue-pulp-1.4.2-1.git.654.58f211f.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.2-1.git.654.58f211f.el6.noarch
katello-1.4.2-1.git.654.58f211f.el6.noarch
katello-common-1.4.2-1.git.654.58f211f.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch


How reproducible:
always
Comment 1 RHEL Product and Program Management 2013-06-14 05:23:57 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Eric Helms 2013-10-08 16:57:38 EDT
This issue led to an error in Katello in how tasks are returned and generated. However, the I noticed that Candlepin was not returning events. I have opened a bug on Candlepin to address this - https://bugzilla.redhat.com/show_bug.cgi?id=1016874
Comment 4 Eric Helms 2013-10-15 07:28:17 EDT
https://github.com/Katello/katello/pull/3130
Comment 7 Og Maciel 2013-10-19 17:47:56 EDT
katello> system tasks --org "Katello Infrastructure" --name qetello02
--------------------------------------------------------------------------------------------------------
                                              Remote tasks

Task ID                          System                       Action            Status
--------------------------------------------------------------------------------------------------------
8a90e0eb41cbdc650141cd4cfc2701aa qetello02 Candlepin Event:  CREATED
8a90e0eb41cbdc650141cd4cff5f01ad qetello02 Candlepin Event:  CREATED
8a90e0eb41cbdc650141cd4d003f01b0 qetello02 Candlepin Event:  CREATED
8a90e0eb41cbdc650141cd4d527801b3 qetello02 Candlepin Event:  CREATED
8a90e0eb41cbdc650141cd4d799d01b5 qetello02 Candlepin Event:  MODIFIED
8a90e0eb41cbdc650141cd7b230b01bf qetello02 Candlepin Event:  MODIFIED
Comment 8 Og Maciel 2013-10-19 17:48:19 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.25-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.25-1.el6sam.noarch
* candlepin-tomcat6-0.8.25-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.3.0-18.el6sat.noarch
* foreman-compute-1.3.0-18.el6sat.noarch
* foreman-libvirt-1.3.0-18.el6sat.noarch
* foreman-postgresql-1.3.0-18.el6sat.noarch
* foreman-proxy-1.3.0-3.el6sat.noarch
* katello-1.4.6-39.el6sat.noarch
* katello-all-1.4.6-39.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.4-1.el6sat.noarch
* katello-cli-1.4.3-24.el6sat.noarch
* katello-cli-common-1.4.3-24.el6sat.noarch
* katello-common-1.4.6-39.el6sat.noarch
* katello-configure-1.4.7-5.el6sat.noarch
* katello-configure-foreman-1.4.7-5.el6sat.noarch
* katello-configure-foreman-proxy-1.4.7-5.el6sat.noarch
* katello-foreman-all-1.4.6-39.el6sat.noarch
* katello-glue-candlepin-1.4.6-39.el6sat.noarch
* katello-glue-elasticsearch-1.4.6-39.el6sat.noarch
* katello-glue-pulp-1.4.6-39.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.4-4.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.0-0.22.beta.el6sat.noarch
* pulp-nodes-parent-2.3.0-0.22.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.0-0.22.beta.el6sat.noarch
* pulp-selinux-2.3.0-0.22.beta.el6sat.noarch
* pulp-server-2.3.0-0.22.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.7-1.el6sat.noarch
* signo-0.0.22-2.el6sat.noarch
* signo-katello-0.0.22-2.el6sat.noarch
Comment 11 Bryan Kearney 2014-04-24 13:10:11 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 12 Bryan Kearney 2014-04-24 13:11:30 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.