Bug 97449 - installer hangs trying to load scsi driver
installer hangs trying to load scsi driver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-15 22:03 EDT by Thorpe Mayes
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-14 12:43:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorpe Mayes 2003-06-15 22:03:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/74 (KHTML, like Gecko) Safari/74

Description of problem:
Here is a summary of my experience, in reverse order (most recent first):

Technician Response


Dear Sir,

There seems to be a problem with the installer not being able to probe your
hardware properly or it may have something to do with the driver not loading as
it should be during the installation. I suggest posting a bug report to our
bugtracking system so that our developers may take a closer look at the driver
that your scsi controller is using. You may get in touch with them through
here:

http://bugzilla.redhat.com

We apologize for any inconvenience.

Regards,
Philip

-------

I tried using linux expert at the boot prompt. Same result.

When I tried using linux noprobe at the boot prompt, I got the following:

1. Warning. No hard drives have been found. You probably need to manually
choose device drivers 
for the installation to succeed. Would you like to select drivers now? Yes/No -
I selected Yes

2. Devices. No special device drivers have been loaded for your system. Would
you like to load any 
now? Done/Add Device - I selected Add Device

3. Devices. What kind of device would you  like to add?  SCSI/Network.  Ok/Back
- I selected SCSI 
and Ok

4. Devices. Which driver should I try? If the driver you need does not appear
in this list, and you 
have a separate driver disk, please press F2. - this is followed by a list of
drivers

If I press F2 I am asked to put my driver disk in the A; drive. The list that
comes up is the same list 
that appears at number 4 (above). When I select the sym...driver from either
list, I get the same 
result: the system hangs loading the driver. 

Any ideas?

Best regards,

Thorpe Mayes

------
Technician Response


Dear Sir,

Try passing this parameter at the 'boot:' prompt after booting from the 1st
install disc:

linux noprobe

Or this one:

linux expert

Regards,
Philip

------
I followed your directions and got the same result. The software hangs while
trying to load the 
SCSI driver. Any further suggetions?

Best regards,

Thorpe Mayes

------
Technician Response


Dear Sir,

Create a driver disk, follow these steps on how to do it:

1. boot either to dos or windows
2. insert disc 1 install cd.
3. execute the 'rawrite.exe' utility from the dosutils directory which is in
install cd1.
4. when prompted to an image file to use, point to 'drvblock.img' which is in
the 'images' directory.

When you're done, boot from the install cd and pass this parameter at the
'boot:' prompt:

linux dd

Insert driver disk when prompted to.

Feel free to write back if you have other concerns.

Regards,
Philip Morales

------
I am upgrading from RH 7.1 to RH 7.3. 

I booted from the RH 7.3 CD. At the Welcome to Red Hat Linux screen the
following 
dialog box appeared:

Loading SCSI Driver
Loading xym53c8xx driver

The process hung at this point. 

My hardware is an ASUS AP1400R server with three scsi hard drives. 

I have no problems running under RH 7.1

Thanks for your help.

Thorpe Mayes


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot rh 7.3 from cd
2.
3.
    

Actual Results:  installer hangs when trying to load the scsi driver

Expected Results:  the installer should load the scsi driver

Additional info:

I contacted ASUS. They said that this server has not had any problems with RH 7.3.
Comment 1 Michael Fulbright 2003-06-18 16:37:59 EDT
I would recommend you try a more recent release (8 or 9) because we have fixed
numerous bugs since the 7.3 release.
Comment 2 Michael Fulbright 2003-07-14 12:43:05 EDT
Closing due to inactivity. Please reopen if you have additional information to
add to this report.

Note You need to log in before you can comment on or make changes to this bug.