Bug 974494 - UI - system events history: events are duplicated when page is reloaded
UI - system events history: events are duplicated when page is reloaded
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Tazim Kolhar
: Reopened, Triaged
Depends On: 1021267
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:38 EDT by Ales Dujicek
Modified: 2014-07-02 10:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:14:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-06-14 05:38:02 EDT
Description of problem:

every time you reload System Details > Events History page,
some of events are duplicated


Version-Release number of selected component (if applicable):
signo-katello-0.0.9-1.el6.noarch
katello-configure-1.4.3-1.git.62.f050662.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.2-1.git.654.58f211f.el6.noarch
katello-all-1.4.2-1.git.654.58f211f.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.90.6c7a175.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-common-1.4.2-1.git.90.6c7a175.el6.noarch
katello-glue-pulp-1.4.2-1.git.654.58f211f.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.2-1.git.654.58f211f.el6.noarch
katello-1.4.2-1.git.654.58f211f.el6.noarch
katello-common-1.4.2-1.git.654.58f211f.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. subscription-manager register --org="orgcon-1371196880" --name system1
2. open Details > Events History, you can see event "admin created new consumer system1". three times!
3. reload Details > Events History, you can see event "admin created new consumer system1". eight times!
4. reload again => more duplications
Comment 1 RHEL Product and Program Management 2013-06-14 05:53:35 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Justin Sherrill 2013-09-13 17:12:08 EDT
This was fixed as part of the system's page rewrite.

https://github.com/Katello/katello/pull/2784
Comment 5 Og Maciel 2013-10-20 17:08:24 EDT
This is currently blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1021267.
Comment 7 Tazim Kolhar 2014-04-28 02:09:02 EDT
VERIFIED
Comment 8 Bryan Kearney 2014-07-02 10:09:35 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.
Comment 9 Bryan Kearney 2014-07-02 10:09:41 EDT
This was delivered in 6.0.3, the Beta version of Satellite 6.0
Comment 10 Bryan Kearney 2014-07-02 10:14:30 EDT
This was delivered in the Satellite 6 Beta (6.0.3)

Note You need to log in before you can comment on or make changes to this bug.