Bug 974495 - rsyslog 7.4.0-1 100% CPU load
rsyslog 7.4.0-1 100% CPU load
Status: CLOSED DUPLICATE of bug 974132
Product: Fedora
Classification: Fedora
Component: rsyslog (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tomas Heinrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 05:40 EDT by Constantin Dunayev
Modified: 2016-09-20 00:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 07:22:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Constantin Dunayev 2013-06-14 05:40:55 EDT
Description of problem:
after upgrade to 7.4.0-1 rsyslog eats 100% of cpu, /var/log/messages grows to 300 MB, full with messages dated June-4-2013 (but today is June,14)

Version-Release number of selected component (if applicable):
7.4.0-1.fc19

How reproducible
every boot

Steps to Reproduce:
1. yum update rsyslog
2. reboot

Actual results:
rsyslog eats 100% of cpu, /var/log/messages grows to 300 MB, full with messages dated June-4-2013 (but today is June,14)

Expected results:
normal behavior

Additional info:
yum downgrade rsyslog (to version 7.2.6)closes the problem
Comment 1 Constantin Dunayev 2013-06-14 06:32:53 EDT
Here is part of /var/log/messages:

Jun 14 11:57:08 horse-fedora kernel: [   17.277833] i2c i2c-6: Found a DME1737 c
hip at 0x2e (rev 0x8a).
Jun 14 11:57:08 horse-fedora kernel: [   17.286614] dme1737 6-002e: Optional fea
tures: pwm3=yes, pwm5=no, pwm6=no, fan3=yes, fan4=yes, fan5=no, fan6=no.
Jun 14 11:57:08 horse-fedora kernel: [   17.290277] dme1737 6-002e: Non-standard
 fan to pwm mapping: fan1->pwm1, fan2->pwm2, fan3->pwm3, fan4->pwm4. Please repo
rt to the driver maintainer.
Jun  4 19:24:08 horse-fedora modem-manager[435]: <info>  Loaded plugin 'AnyData'
Jun  4 19:24:08 horse-fedora modem-manager[435]: <info>  Loaded plugin 'SimTech'
Jun  4 19:24:08 horse-fedora modem-manager[435]: <info>  Loaded plugin 'Gobi'
Jun  4 19:24:08 horse-fedora modem-manager[435]: <info>  Loaded plugin 'Option'
Jun  4 19:24:08 horse-fedora modem-manager[435]: <info>  Loaded plugin 'Huawei'
Jun  4 19:24:09 horse-fedora modem-manager[435]: <info>  Loaded plugin 'Longchee
r
Comment 2 Constantin Dunayev 2013-06-14 06:40:24 EDT
Ahother cut from /var/log/messages (attention to date/time)

Jun  4 19:24:19 horse-fedora systemd: PID 606 read from file /run/sm-client.pid
does not exist.
Jun  4 19:24:19 horse-fedora systemd: Started Sendmail Mail Transport Client.
Jun  4 14:06:35 horse-fedora colord: device removed: xrandr-Samsung Electric Com
pany-SyncMaster-HVDXC55996
Jun  4 14:06:35 horse-fedora colord: Profile removed: icc-6a8810d371888a14b3b22b
cba6fa7521
Jun  4 14:06:38 horse-fedora gnome-keyring-daemon[4068]: Gkm: using old keyring
directory: /home/constantin/.gnome2/keyrings
Jun  4 14:06:38 horse-fedora gnome-keyring-daemon[4068]: Gkm: using old keyring
directory: /home/constantin/.gnome2/keyrings
Jun  4 14:06:38 horse-fedora gnome-keyring-daemon[4068]: couldn't register in se
ssion: The name org.gnome.SessionManager was not provided by any .service files
Jun  4 19:23:42 horse-fedora systemd[1]: systemd 204 running in system mode. (+P
AM +LIBWRAP +AUDIT +SELINUX +IMA +SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ)
Jun  4 19:23:42 horse-fedora systemd[1]: Running in initial RAM disk.
Jun  4 19:23:42 horse-fedora systemd[1]: Set hostname to <horse-fedora.home.net>
.

All these messages have appeared in 3-4 minutes after start at 11:57am EEST June,14,2013
Comment 3 Constantin Dunayev 2013-06-14 06:45:54 EDT
downgraded 7.2.6 does not switch date/time
Comment 4 Constantin Dunayev 2013-06-14 06:54:53 EDT
It seems, that it doesn't switch time, it simply repeats the random parts of older logs.
The same messages are found in previous /var/log/messages-20130609
Comment 5 Constantin Dunayev 2013-06-14 07:18:26 EDT
I have found an article, describing the same problem:
http://www.happyassassin.net/2013/06/14/fedora-1920-logfile-explosions/
Comment 6 Constantin Dunayev 2013-06-14 07:22:18 EDT

*** This bug has been marked as a duplicate of bug 974132 ***

Note You need to log in before you can comment on or make changes to this bug.